Back to the main site

Witcher 3 GPU minimal requirement error


#1

I install with Lutris Witcher 3 - Wild Hunt from gog. Installation went fine. When I try to run an error appear:

GPU does not meet minimal requirements. Support for DirectX 11 is required

I have Dell Inspiron 15 7577 with Nvidia GTX 1050. I use Manjaro and have last drivers installed:

primusrun glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 1050/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 396.24
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 396.24
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)

I check primusrun option in configuration tab.
Can anyone help me?


#2

DXVK 0.61 requires 396.24.02. Right-click Witcher 3 in your library > Configure > Runner options > Highlight 0.61 and change it to 0.54

Also disable nvapi and nvapi64 in winecfg


#3

I don’t have 0.54 in my lutris so I type it manualy but that doesn’t help. I choose 0.52(default) but also have the same error. Game works when I go to game dir and start it from terminal with command:

primusrun wine Witcher3.exe

#4

VirtualGL / Primus don’t support Vulkan. You will have to setup PRIME and PRIME Synchronization with “output” to use vulkan.

https://devtalk.nvidia.com/default/topic/957814/linux/prime-and-prime-synchronization/1


#5

Thanks, I disable DXVK and game launch. So I must uninstall bumblebee and install Prime to make dxvk works with games?


#6

I don’t know what distro you are using. And I’m new at Bumblebee / Prime myself. However, I don’t think you need to uninstall Bumblebee. Its just a different way of using your dGPU. Though I doubt you can use stuff together at the same time.

I know Ubuntu has a Prime Select. Fedora has something similar I think.

For Arch I haven’t found that yet, however they do have “nvidia-xrun” packaged. Which is basically Prime Select on a different tty.

Anyways, this is all I can tell you. The rest is up to you.


#7

I install Prime but don’t know how to run game with DXVK. When I try to run from Lutris I have black screen and it looks like complete shutdown.


#8

Setting up Prime for your distro is something you should discuss in your Distro’s forums, and not here. Once you have set it up correctly, your DE/WM will run completely on your nvidia card, and you should have no problems running games.

Also if you have set it up correctly, remember to actually insall Vulkan, Vulkan 32 bit, and the icd-loader, and icd-loader 32 bit.


#9

Hi, I install vulkan and I have solution that works very well with Dark Souls 3, but I don’t use it via lutris, just regular wine steam installation. Nice guy from github give me some dxvk.061-xxx implementation that works great for me. I have to copy windows folder to my .wine/drive_c/ folder and thats it. Can You tell me where in lutris installation copy that?


#10

I know nothing about Steam / WineSteam. Perhaps someone else can help you.


#11

That is not what I mean. I copy that dxvk.0.61-xxx windows folder to my lutris game witcher folder but still have black screen. I also start game with regular wine (not from lutris) and game works but with graphics glitches. So I think that dxvk.0.61-xxx is not right for W3. Can You point me what I should do? Do I have to install game one more time or make some changes in witcher configuration? I know forsure that my vulkan works with Dark Souls 3 so it should also works with lutris.


#12

DXVK 0.61 does not support less than 396.24.02 that .02 is important. You only have 396.24.00. Either upgrade your driver or use DXVK 0.54


#13

I know, that why I have some 0.61 mod and Dark Souls 3 works on it (Witcher 3 also but with blinkink ground and some terrain).
I don’t see 0.54 in popup menu in witcher 3 configure tab. So I have to choose manual and type: 0.54?


#14

That sounds like tessellation and that don’t work on anything but 396.24.02


#15

I have black screen when launch. Can You point me what are right configs in lutris, winecfg and configuration for Witcher3?


#16

Try unchecking “Allow Flipping” in Nvidia settings under OpenGL.


#17

I don’t have that option i nvidia settings:


#18

HI, I install game again with lutris and now it works even with dxvk 0.61 but I have that terrain blinking (also on 0.54):

when I launch game like normal wine app from terminal it looks like that:
link


#19

Now I have black screen again on dxvk 0.54 and 0.61 :confused: and I don’t make any changes.


#20

I have this problem in manjaro too, looks like manjaro not have the 396.24.2 version of nvidia driver only 396.24, maybe is the same problem that you show, in Ubuntu runs nice with the lastest drive.