Winesteam runner fails to start

First off I’d like to say that I’m really liking lutris quite a bit, and have gotten a Windows game (Star Wars: The Old Republic) to work with little to no issues.
However, i’ve run into technical difficulties when it comes to using the Winesteam runner. I have followed advice on these forums for installation, and apparently have it installed, but when I try to run it through right-clicking it, it flashes “updating steam” for half a second, then does “Connecting Steam Account:”, and usually also “Updating user configuration” or something along those lines, then crashes with no error message. It never actually loads steam. This is what I think may be causing my other issue, which is that the Call of Duty: World at War installer does not seem to work, hanging up forever at “Installing game content”.
I have attempted using different Wine versions as well as uninstalling and reinstalling the winesteam runner.
What should I do to fix this?

In addition, I am also now having issues installing Path of Exile, with all 3 options failing in some way. The oldest one claims it needs options to an execute command or something like that, the steam one fails because winesteam isn’t working as mentioned previously, and the most recent one does not install pathofexile.exe, meaning after the initial setup, trying to run the game will cause lutris to complain about the file not being there. The pathofexileinstaller.exe in the prefix does not launch when run manually.

Delete ~/.local/share/lutris/runners/winesteam and reinstall Wine Steam. Once it finishes installing close and reopen Lutris then right-click > run. Let it update and sign in to you Steam account. Finally close Steam and rerun the installer for CoD WaW.

Hello, cxf.
I deleted ~/.local/share/lutris/runners/winesteam and reinstalled winesteam through the manage runners menu. I then closed and reopened lutris and ran winesteam through the right click menu. It updated and then flashed the sign in window for a couple seconds, then immediately closed (crashed?). I ran it again and was able to log in with username and password + SteamGuard code. However, after that it proceeded to do the same thing where it says “Updating user configuration” and then fails to actually launch steam.

Hello, Lutris Forums.
Today I attempted to run steam through the right-click menu again, with no success. I tried using different wine versions I happened to have installed, and those did not have any success either. I even went back to Wine 2.15 as that is the version used in the tutorial video commonly linked to for this sort of issue and while it didn’t work, it does at least have an error message, which should be attached to this post.Screenshot_2018-05-26_14-30-29
I also have a copy of the “Show Details” error log for when this happened. I’ll post it if you think that would help.