Back to the main site

Wine steam games get black screen on start up (work fine without steam)


#1

Hello,

This is a wine + steam issue as opposed to a direct lutris issue, but I would imagine this is the most knowledgeable place to ask about it, so here we go. I’ve gathered a fair bit of info, so I’ll use bullets to make it easier to read.

The short version is that steam (on wine) games don’t seem to launch successfully anymore. They either launch directly into a black screen with a custom mouse and nothing else or (in the case of south park), they play their logo/intro videos and then go into the same black screen with a custom mouse. Here are the details and what I’ve tried (the most interesting is the witcher 3 case):

---- Machine specs ----
OS: Fedora release 27 (Twenty Seven) x86_64
Kernel: 4.18.16-100.fc27.x86_64
Packages: 2870
Shell: bash 4.4.23
Resolution: 2560x1440
DE: KDE5
WM: KWin
Theme: [KDE], Adwaita [GTK2/3]
Icons: [KDE], Adwaita [GTK2/3]
Terminal: /dev/pts/3
CPU: AMD Ryzen 5 1600X (12) @ 3.600GHz
GPU: NVIDIA GeForce GTX 950
Memory: 4815MiB / 16035MiB

---- South Park: Stick of Truth ----

  • I’ve played this game through on a previous install of fedora on this very machine before
    • I’ve also had it have the same failure mode before. My solution then was to re-install the OS and hope (and it worked); would rather avoid that this time
  • Currently, it launches, plays the intro videos fine (the very first one has a video delay, the rest are perfect)
  • after the videos, it hangs on a black screen with a custom mouse
  • moving the mouse or pressing keys doesn’t change anything (no menu sounds, etc)

---- Frostpunk ----

  • This game ran initially off of steam
  • I installed lutris to get DXVK support and that changed something (not sure what) that seems to have broken it
  • Now its similar: launches immediately (no videos) into a black screen with a custom mouse

---- Witcher 3 ----

  • Similar to Frostpunk, it ran perfectly fine (though extremely slowly without DXVK)
  • I installed lutris to get DXVK and now it’s exactly the same as Frostpunk
    • launches into immediate unresponsive black screen with custom mouse
      ****- The interesting part is launching it without steam (running witcher3.exe) runs the game perfectly fine
    • please note that of the 3 games, the witcher is the only one that does NOT launch steam when one runs the .exe directly
  • all behavior is the same regardless of if
    • it’s done through the terminal or
    • lutris and regardless of if DXVK is on or off (of course it’s extremely slow without DXVK, but it runs fine otherwise)
  • all runs are on the same lutris wineprefix
  • blowing away .local/share/lutris/ and starting fresh doesn’t change any of this
    • reinstalling steam, game, etc are part of this and have no effect either

This leads me to believe there is some weird interaction between wine and steam. Not sure what.

I’ve looked throught the logs and see lots of stubbs, warnings, errors and cannot tell which is a red herring (hopefully someone here can help?)

I have 4 logs for the witcher 3 (without DXVK):

The “Last game log” when running through lutris:


#2

The terminal output (STDOUT and STDERR merged):

I’d be happy to get more logs if that would help. The only thing I can think to do myself is to diff the logs, but that doesn’t seem like a very fruitful way to go forward. I’d appreciate any thoughts/help.

Thanks in advance!


#3

#4

I am experiencing this exact same issue with Fallout New Vegas and Fallout 3. If I replace FalloutNV.exe with a DRM-free executable and run the game directly, it works flawlessly. However, both the original and the DRM-free versions of the executable have the issue when launch through Steam. The process immediately becomes a zombie and is completely unresponsive. Interestingly enough, Oblivion (another game on the same engine) works completely fine when launched through Steam. (The problem doesn’t seem engine-related to me anyhow, as you are having the problem with completely different games.)

My log isn’t from Lutris itself (I had to disable the process monitor as it causes Steam to crash constantly), but it does show the same stack overflow exception that you have in your Witcher 3 log when launched through Steam.

Distro: 64-bit OpenSUSE Leap 15.0
Kernel: 4.12.14-lp150.12.25-default
CPU: AMD Ryzen 7 2700x
GPU: Nvidia GTX 960
Nvidia driver: 390.87
64-bit Wine prefix
Log: https://paste.ubuntu.com/p/9f54XSsB2y/

I have tried older Wine versions, using Wine packaged by my distribution, disabling esync, pba and DXVK and nothing made any difference. We do have similar specs (AMD Ryzen + Nvidia 900 series), perhaps that has something to do with it? Which Nvidia driver version are you on? Also, I’m guessing your prefix is 64-bit as well?


#5

Wine 3.21 fixed this for me.