Wine is not available for the X86_64 architecture

I keep encountering an issue when I try and install Neverwinter Nights 2 through the program. The error message I keep getting after selecting the install folder and before selecting the installation files from GOG is “wine is not available for the X86_64 architecture” and was wondering if there’s anything I can do to make it work on my end, or if I need to wait for the script to be fixed if it’s somehow busted. Thanks in advance for the help if you’re able to give it.

Can anyone tell me how to solve this issue or at least give me an idea of where to begin doing so if they can’t solve it themselves?

I’m not sure why you’d need wine if you have Windows? The only installer I can find for Neverwinter Nights 2 is for Windows only. The installer still references wine and only a 32bit version. No idea why. You’ll need to fix the installer. No idea how, I don’t know that game.

I’m running Arch. I have no idea where you got the Windows thing from at all. I’m running Arch and while trying to install the game through the Lutris program that error (wine is not available for the X86_64 architecture) keeps popping up.

Maybe I’m reading the game tags wrong on this site. But have a look at and you’ll see that the script tries to install 32 bit. Why this is not working for you I don’t know, but you can edit the script. Since nobody answered you until now you are probably alone in this.

But that’s just it, I don’t know how to change scripts myself. I’m gonna see if I can just work out how to install it myself with no script. Will report back if I find anything in case someone else needs this thread in the future.

Ok, I actually managed to get it working. Sorry for the late response, I got distracted and fell asleep. Anyways, I just downloaded the files from GOG and ran the exe through wine program loader. After installation, I restarted my computer (had a new kernal update anyways) and then tried to run the game through “nwn2.exe” and it just gave me a black screen and 2 errors both talking about needing 3D Hardware Acceleration. I decided to manually add the game into Lutris labeling it a wine game and choosing nwn2.exe as the executable. It gave me the exact same results. Then I changed the wine version from 3.8 (which was the default) to the older “staging-2.18-x86_64” and now it works. There seem to be some issues to work out, such as fire having missing texture errors, and some controls seeming to not work entirely correctly. perhaps toying around with settings and wine versions will solve that. But anyways, the issue seems resolved.

I had this same issue. For me, the problem was an incorrect wine version in the install script. I changed the wine version in the install script and everything installed as expected.

You can do this by clicking the dropdown arrow next to install for the game you are trying to install, click “Edit Installer”. Then go to the line in the script that lists the wine version. Change that version to one that is in your “Managed Versions” of wine (preferrably one that closely resembles the one the script wanted in the first place), “Save Draft” and "click on “Test this installer”. If it works you should click “Submit to moderation”. That way you might fix the issue for others. :slight_smile: