Back to the main site

Will Ubuntu 18.10 be supported?


#1

Is there a plan to support Ubuntu 18.10, and if so when?


#2

I’m running Lutris and all my games on 18.10 without any trouble.


#3

@ixanis, did you do anything custom to install Lutris on 18.10? Looking at the bash script, the installation doesn’t handle the version number. Further, there’s no directory on the openSUSE deb download server corresponding to 18.10.

If it just works fine, it would be nice to have a deb that explicitly supports the release.


#4

I don’t recall having to do anything other than run the script, although now that I think of it, I may have had to make some changes to my apt repo lists.

I’m using Xubuntu, if that matters.


#6

I run Lutris on a clean install of Ubuntu 18.10. One thing I noticed is that, after reinstalling the Blizzard App, it does show the error “A required DLL could not be found” even though I installed Vulkan for 32 bits for DXVK. When I fall back to OpenGL, everything is fine, although the performance is worst. My advice, don’t upgrade so quickly.

Edit: Run for World of Warcraft.


#7

I decided to risk it, and dist-upgraded to 18.10. Everything appears to work fine, the Battle.net app and Overwatch both load and run without errors. Performance feels the same. I’m running an Ubuntu minimal install.


#8

I had an issue like this as well, but not from upgrading OS. It appeared with a DXVK update to 0.90. I changed versions back to .80 and it worked perfectly again. Finally, my Vulkan update came through earlier today and it broke my WoW until I switched it to back to 0.90. I’m still on 18.04 so this problem might not have anything to do with the new kernel…?

Edit: I said Mesa, I meant Vulkan update


#11

I didn’t upgrade the OS, it was a clean install, so maybe it had something to do with the packages. I can’t be sure, but I don’t think it’s the new kernel version.

Anyway, I went back to Ubuntu 18.04, so I can’t troubleshoot the error further.


#12

Gotta wait for OpenSuse Build Service to support 18.10 first. For now you can use this deb file. https://lutris.net/releases/lutris_0.4.21_amd64.deb


Ubuntu 18.10, cant install lutris