When I wanna install from Ubisoft it says I'm missing "libnvidia-glvkspirv.so.530.41.03", where can I find this?

I’m new to linux so please excuse the lack of knowledge. I’ve tried look for this but I can’t find it I only found a file called “libnvidia-glvkspirv_530.41.03” on the debian site. If anyone knows how to fix it I’d really appreciate the help. Thanks in advanced.

(This is what it says)

Your distributor may split packages… you may have a package for your Nvidia driver, but also a separate package for Nvidia vulkan.

Heheh… In Debian (is that what you’re using?) It looks like that nvidia vulkan spirv compiler is a separate package in itself. Try

apt install libnvidia-glvkspirv

You’re going to need the Nvidia driver, Nvidia’s vulkan and it seems, that.


1 Like

Appreciate you bro, going to try it. Linux mint cinnamon btw

Rip unable to locate package. Thanks tho.

I’m perplexed, I can’t find the package online or on synaptic. A workaround I found is to install and play through the Ubisoft launcher.

Mint, I haven’t seen that in a long time, but look for libnvidia- packages for both x86_64 and i386.

You might already have the library, but it fails to load. It may also be the 32 bit one that’s failing. Odd if it works through the Ubisoft launcher though.

1 Like

I tried reinstalling all libnvida- i386 packages and it didn’t work, also there was no x84_64. I did notice in nvida settings my driver version number matchs what it says I’m missing but it’s not exact. Maybe imma try reinstalling drivers.

Appreciate the help, but launcher it is. :laughing:

I used locate libnvidia-glvkspirv.so.530.41.03 and the output indicated that I have it, I’m so confused. It may be a Lutris side issue.