What's Wrong with my game? How to debug?

So I installed world of warships. The launcher ran smoothly, and the download was completed without any problems. However, when I clicked play, the game just crashed. How do I find out what went wrong?

Was there any error message that shows up? You can run lutris through terminal with lutris -d for debugging mode.

Which Version did you install? What kind of GPU are you using? If you use the dxvk one then you can check if msaa is enabled in your preferences.xml You can find that in your wows directory. If it is enabled set it to 0 and test it again

no error messages showed up. I am using lutris 0.4.14. I can’t find preferences.xml in my directory.
Thanks in advance for your help

Ok here are the results I got from running it in debug mode:

GET /launcher/game_launched?installation_id=bd09047c9faddecee2e1a252b3e8dd4183073dc0&tracking_id=&event_date=2018-04-14%2014%3a52%3a14%20-0700&application_id=wows&session_id=728A0F754755C004594FA4967D6D4FFC&chain_id=h15&app_type_id=high&game_language=en&windows_scaling=100&parameter_name=default&launcher_version=3.26.720&client_version= HTTP/1.1
User-Agent: wg::http::curl_http_request 1.1
Host: wgusst-na.wargaming.net
Accept: /

< HTTP/1.1 404 Not Found
< Server: nginx
< Date: Sat0089:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0089:fixme:kerberos:kerberos_SpInstanceInit 65536,0x7cd7e3a0,(nil): stub
, 14 Apr 2018 21:52:14 GMT
DEBUG 2018-04-14 14:52:15,144 [thread]:Processes: monitored: WoWSLauncher.ex (4381:Z)
DEBUG 2018-04-14 14:52:15,144 [thread]:Waiting for processes to exit
DEBUG 2018-04-14 14:52:15,144 [thread]:Removing stdout monitor
DEBUG 2018-04-14 14:52:15,145 [thread]:Thread is no longer running
DEBUG 2018-04-14 14:52:15,145 [thread]:Restoring environment
DEBUG 2018-04-14 14:52:16,882 [game]:Game thread stopped
DEBUG 2018-04-14 14:52:16,884 [game]:Game thread still running, stopping it (state: running)
DEBUG 2018-04-14 14:52:16,892 [game]:World of Warships stopped at Sat, 14 Apr 2018 14:52:16
DEBUG 2018-04-14 14:52:17,226 [wine]:Killing all wine processes: [’/home/brian/.local/share/lutris/runners/wine/staging-3.5-x86_64/bin/wineserver’, ‘-k’]
DEBUG 2018-04-14 14:52:17,227 [wine]: Wine prefix: /home/brian/Games/world-of-warships
DEBUG 2018-04-14 14:52:17,227 [wine]: Wine arch: win64
DEBUG 2018-04-14 14:52:17,538 [wine]:Waiting for wine processes to terminate
DEBUG 2018-04-14 14:52:17,539 [thread]:Restoring environment
DEBUG 2018-04-14 14:52:17,540 [thread]:Killing all remaining processes

I installed the NA version

Try to disable Lutris runtime.

NA version is using DXVK. Make sure you have Vulkan installed on your system. See if there’s worldofwarships_d3d11.log and a worldofwarships_dxgi.log. If there are copy and paste them to your reply.

Also what GPU do you have?

how to do that?

My GPU is Lenovo 3rd Gen Core processor Graphics Controller.
What is DXVK or Vulkan, and why do I need to install it?

I couldn’t find either file. Which directory should they be in?

Yeah I think that’s too old for Vulkan/DXVK.

Just made a non-dxvk installer please use that one.

how do I use it? sorry nub question

Just install the NA version. The one not labeled DXVK. Should be the third one.


Sorry I accidentally deleted my first reply. Do I have to delete the original folder, or can I copy and paste?

You don’t have to redownload. Run the non-dxvk installer and make it up to where it starts downloading the game. Pause it and copy over your game folder to drive_c/Games in the new prefix. After that’s done copying resume download on the client and it should hopefully recognize it as installed.

thanks for the help, testing right now

The game still crashes. Any advice?

Did you run any other games? What is your GPU?

my GPU is Intel Corporation 3rd Gen Core processor Graphics Controller

Type in terminal “screenfetch” copy the output and then “glxinfo | grep OpenGL” copy also and paste it in here please.
Ah and make sure you install “winbind” for your distro the debugger says its missing.