What does this error this error message mean:

/home/user/Games/oolite/oolite-1.86.linux-x86_64.run: 309: exec: -title: not found
I am trying to write an install script to install oolite 1.86.
So far it looks like this:

- file1: https://github.com/OoliteProject/oolite/releases/download/1.86/oolite-1.86.linux-x86_64.tgz
  exe: $GAMEDIR/oolite
- extract:
    file: $file1
- execute:
    args: --keep --noexec
    file: $GAMEDIR/oolite-1.86.linux-x86_64.run
    terminal: true

Try running a chmodx task before executing?

it tried this:

- chmodx: $GAMEDIR/oolite-1.86.linux-x86_64.run
- execute:
    args: --keep --noexec
    file: $GAMEDIR/oolite-1.86.linux-x86_64.run
    terminal: true

However, the same error occurs. Also, when I do the installation manually I do not need to make it executable.

did you use chmod +x “*filename” ?
I have never seen chmodx

Making a file executable

Marking the file as executable is done with the chmodx directive. It is often needed for games that ship in a zip file, which does not retain file permissions.

Example: - chmodx: $GAMEDIR/game_binary

From the manual. I also tried - execute: command: chmod +x $GAMEDIR/oolite-1.86.linux-x86_64.run.
That doesn’t work either.

1 Like