Weird font ingame for League of Legends

I used to use the POL version before they updated the client cause it gave me the best results, even used latest wine staging (2.4 at that point) and it worked very well.

Installed it via Lutris (cause I wanted to move all my games here instead of being in POL) and it got me the new client (it was time to update anyway) but there is a problem ingame, it doesn’t show the letters properly in the chat there. It shows fine in the client though.
Any suggestions?

can it be related to missing msttcorefonts (core fonts by Microsoft)?

Quite possible. I couldn’t find that package in the winetricks gui app. Is there another way to install them?

I see an “allfonts” winetricks package.

Installed it, but no luck. Installed all microsoft fonts one by one as well, but still…

The only one that I’ve installed but isn’t ticked for some reason is the Tahoma one (and it says it isn’t included in the core fonts).
Possible problem: sha256sum mismatch! Rename /home/$user/.cache/winetricks/tahoma/tahoma32.exe and try again.

Soo found the problem after a google search.

"If you have font problems:
-If you’re using AMD, it’s been reported that AMDGPUPRO drivers fix the issue, nvidia proprietary drivers work fine as well. If the problem persists:

right click on LoL in lutris-winetricks-select default prefix-Install windows DLL or component-directx9
then right click on LoL in lutris-brows files-Config-game.cfg and remove x3d_platform=1


Well thanks a lot. It works as it should now.

Hello. Thanks a lot for this video, it “solved” the problem with the font, but got me another problem. Everything in the game was black but the menu, the chat and the shop. All black texture, no HUD or nothing xD

Did this do that to anyone ?

Edit : Nevermind, reinstalling and doing this again fixed things. Thanks for the tips guys :smiley: