Weird bug in with league install script disabling monitor

I am using arch linux and i3 and glorious eggrolls install script. It has worked fine for several months which is amazing. However some update recently (to league) recently broke it for me. When the game launches, it usually takes over one of my monitors. However when it launches now (like, you get past champ select and into the game) it turns off the monitor. This is amazing. I have two monitors, and I run league on the 1920x1080 monitor, and it just turns off that screen entirely. I tried running in single monitor mode on either monitor, and one actually displayed an error codde by flashing its LED as saying

The display is detecting wrong video format or an unsupported resolution.
Verify that your equipment is compatible and restart the computer. If the issue continues, reset the PRAM.

I will try changing the resolution in the config rather than in the game and tell you whats happening
Edit okay that was the issue, this is now fixed for me. Still a weird bug.