Wargaming.net launcher fails to open


There was an update today that broke wargamings launcher for me and I haven’t been able to get it back.

The forums/reddit sites weren’t flooded with OMG the games broke posts so I tried converting to the latest version of wine I could find. I’m at 5.0-rc1 (Staging). But it behaves the same as before.

The logs are:


The text of the lutris-issue-report.jason is:


The terminal output is:


If I think of anything to do I’ll post more.

Here its the same on a PC on Manjaro 5.4 Mesa 20 wine 21, and on a laptop with ubuntu 5.3 mesa 19.2 wine 21.

I have the same errors. :expressionless::confused:

I use:

  • Ubuntu Mate 18.04.3 LTS

  • Kernel Linux 5.0.0-37-generic x86_64

  • Wine lutris 4.21

And I dry already some other Wine Versions and a reinstall of WoT -> same problems…:confused:

It looks like I got the launcher running. I’m downloading the game now.

The fix I used is here,

TLDR: Set winecfg to windows 7, install corefonts, mfc42, msxml6, and vcrun2015 via winetricks.

I don’t know a minimal list of options to enable to get it running.

1 Like

I try the fix. It doens’t work. :confused:

Do you have an idea what programs he install to?

…and perhaps a few more that I clicked in a frenzy…

Hi, try it.

Right click --> Configure --> Wine version on lutris-nofshack
Right click --> Wine configuration --> on tab Application, choose W7

It work for me.

Hello - confirmed! Just changing wine config option from Win 10 to Win 7 fixed it for me!

I have modified the installer for the EU server. Now it works.

Now by default win7 is used instead of win10. :wink: