Back to the main site

Wargaming Gaming Center and WOT Graphics failure

Every thing works fine, but after installation the WGC window is totally black. Links may be there but invisible (cursor changes while moving).
After starting WOT.EXE in wine prefix the ground is black (invisible) too.
This failure occured after the latest Lutris update of WGC installation skrip.
[System]
OS: Linux Mint 20 ulyana
Arch: x86_64
Kernel: 5.4.0-56-generic
Desktop: X-Cinnamon
Display Server: x11

[CPU]
Vendor: GenuineIntel
Model: Intel® Core™ i3-6100 CPU @ 3.70GHz
Physical cores: 2
Logical cores: 4

[Memory]
RAM: 31.3 GB
Swap: 2.8 GB

[Graphics]
Vendor: NVIDIA Corporation
OpenGL Renderer: GeForce GTX 750 Ti/PCIe/SSE2
OpenGL Version: 4.6.0 NVIDIA 450.80.02
OpenGL Core: 4.6.0 NVIDIA 450.80.02
OpenGL ES: OpenGL ES 3.2 NVIDIA 450.80.02
Vulkan: Supported

System Wine: 6.0-RC3
Drivers and system wine are updated.
With driver version 455 failure still exists.

Found this at Wine HQ, maybe it will helps u…

System Wine: 06-RC4 updated, failure still exists.

LOCK:
Running gamemoderun /usr/bin/wine /home/user/Games/wargaming-game-center/drive_c/Program Files (x86)/Wargaming.net/GameCenter/wgc.exe
Initial process has started with pid 3777
Start monitoring process.
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
[0102/192846.642:ERROR:network_change_notifier_win.cc(141)] WSALookupServiceBegin failed with: 0
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
[0102/192849.015:ERROR:network_change_notifier_win.cc(141)] WSALookupServiceBegin failed with: 0
[0102/192849.280:INFO:CONSOLE(1)] “[webChannel] connection established.”, source: qrc:/ui/main.c8e1bc2142e07ede59ad.js (1)
[0102/192851.053:WARNING:angle_platform_impl.cc(52)] compileToBinary(256):
C:\fakepath(75,10-46): warning X3571: pow(f, e) will not work for negative f, use abs(f) or conditionally handle negative values if you expect them
C:\fakepath(97,10-46): warning X3571: pow(f, e) will not work for negative f, use abs(f) or conditionally handle negative values if you expect them

ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
fixme:vkd3d_create_device: Unsupported feature level 0xc100.
fixme:vkd3d_create_device: Unsupported feature level 0xc000.

vulkan issue here, you should verify you installed all neede wine 32 bits dependencies:

When i try to enable 32 bit arch i get this massage:
pkg-config-dpkghook: Warnung: Architecture i38 not defined in architecture tables, ignored
Is this normal or is here same think missing?
Sorry, i came from Windows…

I’m not an Arch expert, but we have some on Discord. Join us on #lutris_support channel.

I followed the instructions, everything seems to bee installed…
The failure occurred after the latest Lutris update of WGC installation scrip and Wine 6.XX versions.
Before this i haven’t any graphic problems.
I tried a lot of Lutris drivers and the system Wine, failure still the same.

Any idea how to fix this??

what if you change wine version?

Withe the latest Update of Linux kernel, Graphic driver, Wine and on, the failure is fixed.
Don’t no what changes but it works…