Back to the main site

Warframe Randomly Freezes


#1

In loading screens sometimes the just freezes. The only way to get out of the Client is to kill it.

Most often it happens when leaving a Zone such as Cetus,

Does someone else have this problem? Or can someone give me some advice how to troubleshoot that problem?

System:
Arch Linux 4.13.9-1-ARCH
plasmashell 5.11.2
lutris 0.4.13-1 from AUR
Warframe up to date starting with Lutris Script without problems

CPU: AMD Phenom™ II X6 1090T Processor
RAM: 8GB
GPU: GeForce GTX 780 Ti
GPU-Driver: 387.22

Frame Rate between 10 and 30 fps with lowest settings on 1080p

As a side qustion: does anyone know why the frame rate is so low? Is it because of the GPU? The CPUs are around 50% usage each, so I don’t think the bottleneck is the CPU


#2

Mine keeps either freezing or crashing when I try to leave navigation!
Please help!
It also Happens when leaving Cetus and it just happened when I tried to leave the venus junction!
Please Help!!!, again.


#3

I used Lutris to install Warframe and then execute the Launcher with a 64bit wine prefix. For me this fixed the freezes

export WINEPREFIX=/mnt/tux_data/Games/wine_prefix/Warframe
export WINEARCH=win64
export LUTRIS_WINEPREFIX="/mnt/tux_data/Games/Lutris/warframe"
export LAUNCHER="${LUTRIS_WINEPREFIX}/drive_c/users/${USER}/Local Settings/Application Data/Warframe/Downloaded/Public/Tools/Launcher.exe"

obviously replace your WINEPREFIX and LUTRIS_WINEPREFIX variables with your install directories

then install a vew needed packets

winetricks -q vcrun2015 xact xinput win7 hosts

Then update the registry (found in your archive.zip in your warframe folder

wine64 regedit /S wf.reg

When all went well you can start warframe with the 64bit prefix

WINEDEBUG=-all wine64 "${LAUNCHER}"

edit: all commands extracted from the Lutris installer


#4

So I’m using Ubuntu 16.04 this looks like it is for Archlinux? am I correct and if so what would I have to change to make it work for Ubuntu? But otherwise thanks for the help!

Also what do you mean by “obviously replace your WINEPREFIX and LUTRIS_WINEPREFIX variables with your install directories”?


#5

yes you are right, I’m on arch-linux. I’m using wine-staging 2.21-1 from the repositories. I don’t have an Ubuntu Box laying around to see which package it is, but use the staging version of wine (they include some experimental features, which boost performance quite a bit)

the variable LUTRIS_WINEPREFIX should point to the folder where Lutris installed warframe. The folder should contain two folders: drive_c and dosdevices. I think the standard install folder would be /home/$USER/Games/warframe

The variable WINEPREFIX is to tell wine to create/use the wine-bottle specified by this variable. With this you can create a separate envrionment with other winetricks-packages installed for each game


#6

Hmm well I tried installing winehq_staging but it did not fix the crashes and it also made warframe load the levels really slowly, I am now trying to reinstall wine but it now won’t let me, I have uninstalled winehq_staging but I still cannot reinstall wine help!!! :cry:

Im gonna try reinstalling everything. wine, winetricks, lutris and warframe!


#7

Nope did not help. Now it crashes even more than before and it take soo long to load that other people have practically finished the level before I even start playing someone please help!!!


#8

now it does not even run it just says “update Di”

I ran it in a terminall and I got this if it helps :

C:\Program Files\Warframe>msiexec /i Warframe.msi
wine: cannot find L"C:\windows\system32\winemenubuilder.exe"
wine: cannot find L"C:\windows\system32\winemenubuilder.exe"
[1222/122828:ERROR:main_delegate.cc(724)] Could not load locale pak for en-US
[1222/122828:ERROR:network_change_notifier_win.cc(155)] WSALookupServiceBegin failed with: 8
[1222/122828:ERROR:proxy_service_factory.cc(136)] Cannot use V8 Proxy resolver in single process mode.

that was when it stopped.

If it helps when I looked in C:\windows\system32 i did find winemenubuilder.exe so im not sure what is going on but i extremley annoyed!


#9

could you provide more info? how are you trying to start warframe? When and what does say “update Di”


#10

Good news I fixed it. it now works the same as it did before, with the random freezing. I fixed it by upgrading again to Ubuntu 18.04 (accidentally I was aiming at 17.10) then by reinstalling lutris and Warframe and so on. Also thanks for helping smvader fix his Warframe as I was the one who actually had to physically do it! (we’re friends). But I would still like to know if there is a fix for the random freezing thing so any help is much appreciated.


#11

I’ve updated my startscript and created a Gist for it. Please test and ask if anythings not working :slight_smile:

with the script one can choose to start warframe in a 32bit or 64bit wine prefix (I’m using the 64bit prefix and the freezes went away)

  • update user defined constants wine_prefix_base, download_dir and download_dir_windows
  • double check the paths
  • run ./startscript_warframe.sh --install
  • this sets up a 64bit wine prefix (bottle), installs needed packages with winetricks, updates the wine registry, and creates a basic configuration file
  • run ./startscript_warframe.sh --update
  • this downloads the MSI file from the official warframe homepage and uses Warframe.x64.exe (or Warframe.exe) to update the gamefiles in download_dir
  • in the end the MSI file is started, which is able to update Launcher.exe
  • play Warframe

to play with the 32bit bottle add --32bit to the commands


#13

I’m confused? How do I run it? I’ve tried copying it into a text document and running it in terminal (by pasting the filenames) but nothing works!

Sorry to be a pain but can you help me run it?

Do I have to put it in a certain place?
I also noticed that it had a: user+email=’’ " line
would I be correct to put my email for the game login in there?

Thanks for all the help so far as I’m kinda new to this thing as I’m just a teenager doing my computer science GCSE along with all the other ones. :angel:

I also assume its a bash script?


#14

yes it is a bash script. Download it and put it anywhere you want. Then make it executable. The easiest way is to open a terminal and execute

chmod +x startscript_warframe.sh

before launching you also need to make sure you have wine-staging (or how your staging version of wine is called on your distribution) and wget installed
also update update the following variables

# user defined constants
wine_prefix_base="/home/${USER}/Games/wine_prefix/Warframe" # wine bottles, script will append '_amd64' or '_i386'

# WARNING: keep download_dir and download_dir_windows in sync!
# specify the download folder, where all the game files are
download_dir="/home/${USER}/Warframe/drive_c/Program Files/Warframe/Downloaded"
download_dir_windows="z:\\\\home\\\\${USER}\\\\Warframe\\\\drive_c\\\\Program Files\\\\Warframe\\\\Downloaded"

I updated the variable download_dir to be the Downloaded dir inside my Lutris Warframe install. That way I only have the game files once and can launch them with lutris or with my script. If you change download_dir you MUST also change download_dir_windows. The second variable is written into the Windows registry for the launcher to find the Downloaded folder

Optionally you can update your email and Video-ram variables. If the email is set, it is used to create the default configuration file for the Warframe client. The video ram can be set to the amount of video ram your graphics card has

video_memory_size=2048 # Video RAM of your GPU
user_email="" # your email, set in basic config (optional)

now that you set all the variables you can start using the script.
First prepare the wine prefix and all the needed configurations

./startscript_warframe.sh --install

Then update the MSI-file and the Warframe game files in the Downloaded folder

./startscript_warframe.sh --update

After updating the warframe launcher will be started automatically. If you know that your gamefiles are up to date you can just start the launcher

./startscript_warframe.sh

If you want to start with the 32bit prefix just append --32bit to the above commands

./startscript_warframe.sh --32bit --install
./startscript_warframe.sh --32bit --update
./startscript_warframe.sh --32bit

#16

I got the script to run but, when the launcher is about to load I get an error message from wine saying it cannot be run!

This leads me to believe that the main issue lies with wine, but I am afraid to mess about with wine because last time I did that it broke Warframe completely so unless there is a clear solution I really have no idea if I can make it work.

The errors details are:

Unhandled exception: page fault on read access to 0x00000004 in 32-bit code (0x122eac5f).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:006b GS:0063
EIP:122eac5f ESP:0033e490 EBP:0033e4bc EFLAGS:00210246( R- – I Z- -P- )
EAX:00000000 EBX:00000000 ECX:00000000 EDX:0033e44b
ESI:00000000 EDI:7b4788d0
Stack dump:
0x0033e490: 00000003 00000000 7b4788d0 001c2050
0x0033e4a0: 001c2064 001c2064 00000003 00000000
0x0033e4b0: 00000000 00000000 00000014 0033e4d4
0x0033e4c0: 122eabc1 000000b8 00000000 000000b8
0x0033e4d0: 000000b8 0033e500 122e9214 0033e554
0x0033e4e0: 00000000 001bf6d8 0033e4d4 7b410000
Backtrace:
=>0 0x122eac5f in libcef (+0x22eac5f) (0x0033e4bc)
1 0x122eabc1 in libcef (+0x22eabc0) (0x0033e4d4)
2 0x122e9214 in libcef (+0x22e9213) (0x0033e500)
3 0x11b82972 in libcef (+0x1b82971) (0x0033e514)
4 0x1103066d in libcef (+0x103066c) (0x0033e55c)
5 0x110302ba in libcef (+0x10302b9) (0x0033e580)
6 0x1100dafa in libcef (+0x100daf9) (0x0033e678)
7 0x00429f74 in launcher (+0x29f73) (0x0033e6a0)
8 0x0040f33a in launcher (+0xf339) (0x0033e7a0)
9 0x00406d25 in launcher (+0x6d24) (0x0033f368)
10 0x7fbcfa5a (0x0033f398)
11 0x7fbd00aa (0x0033f3e8)
12 0x7fbd25aa (0x0033f438)
13 0x7fb9468e (0x0033f4a8)
14 0x7fb9b3de (0x0033f508)
15 0x7fb9b6a0 (0x0033f558)
16 0x7fbc6326 (0x0033f6f8)
17 0x7fbc0195 (0x0033f768)
18 0x004088e8 in launcher (+0x88e7) (0x00400000)
19 0x00000003 (0x00905a4d)
0x122eac5f: cmpw 0x4(%ecx),%ax
Modules:
Module Address Debug info Name (45 modules)
PE 400000- 535000 Export launcher
PE 10000000-12f89000 Export libcef
PE 7ac10000-7ac1b000 Deferred riched20
PE 7b410000-7b5ad000 Deferred kernel32
PE 7bc10000-7bc14000 Deferred ntdll
PE 7dd00000-7dd04000 Deferred rsaenh
PE 7dd40000-7dd44000 Deferred msftedit
PE 7e710000-7e751000 Deferred crypt32
PE 7e7e0000-7e7e4000 Deferred iphlpapi
PE 7e800000-7e803000 Deferred netapi32
PE 7e830000-7e833000 Deferred secur32
PE 7e860000-7e875000 Deferred oleacc
PE 7e8c0000-7e8c3000 Deferred dhcpcsvc
PE 7e8e0000-7e8f1000 Deferred urlmon
PE 7e970000-7e973000 Deferred userenv
PE 7e990000-7e995000 Deferred jsproxy
PE 7e9b0000-7e9b6000 Deferred winhttp
PE 7e9e0000-7ea79000 Deferred comdlg32
PE 7ead0000-7eada000 Deferred winspool
PE 7eb10000-7eb13000 Deferred usp10
PE 7eb50000-7eb53000 Deferred api-ms-win-core-sysinfo-l1-2-1
PE 7eb70000-7eb73000 Deferred api-ms-win-core-localization-l1-C:\windows\system32\api-ms-win-core-localization-l1-2-1.dll
PE 7ed80000-7ed83000 Deferred api-ms-win-core-fibers-l1-1-1
PE 7eda0000-7eda3000 Deferred api-ms-win-core-synch-l1-2-0
PE 7edb0000-7edb4000 Deferred winex11
PE 7ee40000-7ee44000 Deferred imm32
PE 7f080000-7f084000 Deferred ws2_32
PE 7f0b0000-7f0ba000 Deferred mpr
PE 7f110000-7f114000 Deferred psapi
PE 7f130000-7f148000 Deferred wininet
PE 7f1a0000-7f1a3000 Deferred wtsapi32
PE 7f1c0000-7f1c4000 Deferred uxtheme
PE 7f1f0000-7f1f3000 Deferred msimg32
PE 7f200000-7f22f000 Deferred comctl32
PE 7f300000-7f309000 Deferred msacm32
PE 7f330000-7f3a8000 Deferred winmm
PE 7f3f0000-7f3f8000 Deferred oleaut32
PE 7f520000-7f524000 Deferred rpcrt4
PE 7f5a0000-7f5a8000 Deferred ole32
PE 7f6d0000-7f6d8000 Deferred shlwapi
PE 7f750000-7f8b0000 Deferred shell32
PE 7f990000-7f994000 Deferred advapi32
PE 7fa00000-7fa07000 Deferred gdi32
PE 7fb40000-7fb7c000 Deferred user32
PE 7ffd0000-7ffd4000 Deferred version
Threads:
process tid prio (all id:s are in hex)
0000000e services.exe
00000020 0
0000001f 0
00000017 0
00000016 0
00000014 0
00000010 0
0000000f 0
00000012 winedevice.exe
0000001e 0
0000001b 0
0000001a 0
00000019 0
00000018 0
00000013 0
0000001c plugplay.exe
00000022 0
00000021 0
0000001d 0
00000023 explorer.exe
00000028 0
00000027 0
00000026 0
00000025 0
00000024 0
0000002d (D) C:\users\craftygeek\Local Settings\Application Data\Warframe\Downloaded\Public\Tools\Launcher.exe
0000002e 0 <==
System information:
Wine build: wine-2.0.3 (Ubuntu 2.0.3-1ubuntu1)
Platform: i386 (WOW64)
Version: Windows 7
Host system: Linux
Host version: 4.13.0-17-generic

Hope this helps :sweat_smile:

Thanks for all the help so far.


#17

your wine install of your system is too old and not a wine-staging version and therefore you are missing the CSMT patches.

I think Lutris uses at least wine 2.19 staging, on my machine it useses 2.21 staging


#18

I think I may have finally fixed the issue. I have changed the runner options in lutris and the prefix architecture to 64 bit. If i right click on Warframe in my library I get the option to change the wine staging version, and it was set to the ubuntu default and I change it to staging-2.21-x86_64 and I change the prefix architecture to 64 bit. I hope this helps gonna test it over the next few days thanks for all the help so far.