Back to the main site

Warframe periodic hanging

I installed the game with this script: https://lutris.net/games/warframe/
The game indeed runs, I can login and get the game working.

However, even in the login page, my computer will hang for 10-40 seconds every minute. By hang, I mean that not only is the screen not updated but the system is completely unresponsive to inputs during this time. When the game is not in this hung state, it reports a framerate of 60 fps.

Here is the game’s log from just entering the login menu: https://paste.ubuntu.com/p/VKRT7Qgsn4/

Here is also the output of my issue report: https://paste.ubuntu.com/p/tKTYYFHD5p/

Have you tried running steam proton version?

Yes, I had the same sort of issue when I installed it via steam+proton (after having to switch proton versions to get around the issue of the patcher crashing with 5.0-7).

I thought this may be some hardware issue. I ran htop while the game is running, but there is plenty of RAM available and the CPU cores are mostly unused. Is it possible that there is an issue with my GPU configuration? Or something about xfce?

If you look at line 42 of the game’s log, it appears to recognize my GPU (Nvidia Quadro P2000).

If anyone has suggestions for debugging this, I would very much appreciate the advice.

0137:fixme:imm:ImmGetDescriptionW (0000000004090409, 000000000052D510, 0): semi stub
0137:fixme:imm:NotifyIME IMC_SETCANDIDATEPOS
0200:fixme:dwrite:dwritefontface5_HasVariations 0xb4ee10: stub

This lines repeats a lot.Maybe something with dwrite?
Have you tried disabling dxvk?
Could it be some sort of kernel bug?Have you tried with a different kernel version?

Disabling dxvk causes the game to crash while loading the login menu.

I tried running with Linux 5.6.11-1 and 4.14.179-1. The game behaved the same way with both kernels.

01ec:err:vulkan:X11DRV_vkCreateWin32SurfaceKHR Failed to allocate client window for hwnd=0x20096
err: Failed to create surface
Have you tried to updating/reinstalling gpu drivers?Does vulkan work well with other games?Have you tried with some older wine versions?

I have been able to play Heroes of the Storm with wine and Borderlands 2 with proton without any issue. I think those both use vulkan.

The GPU drivers are up to date, reinstalling didn’t make a difference.

I launched the game with wine 4.21, but it crashed. Versions 5.4, 5.6-2, and 5.7 run but have the hanging issue.

Could you try to experimenting with some lutris options like disable or enable esync/disable lutris runtime/prefer system libraries/enable or disable enable aco shader compiler. Have you tried running directly without lutris ? Do you have another linux distro to test if problem persists?