Back to the main site

Warframe no longer works


#1

Hi there, the problem is that whenever Warframe has an update (which is quite often) It refuses to work after the update. The workaround i have found for this is annoying and long - I have to cut the downloaded folder out of Warframe, delete Warframe, and reinstall. When I am asked to run the game again, I have to merge the old downloaded folder with the new one.

Now however, after the latest update, which I tried to install today, I did the workaround like normal, but when i went to reinstall it, the first download, and installation, doesn’t seem to take long enough, then when I am asked to launch the game, I merge the two folders, only to find the new downloaded folder is in a different location, so I think “okay fine” and merge them in the new location, only now instead of going to the black wine window that looks like a terminal, it starts running a process in Xterm, and begins downloading stuff at a much faster rate than normal, gets to around 50%, and gives up. Also along the way, it says it cannot find many files that are clearly there… Please help someone!!!.

Also if anyone can find a less time consuming workaround for each time Warframe updates, that would be helpful too.

If this helps, I’m running Ubuntu 18.04 (not my idea)


#2

i cant install it on Manjaro it says OSError(5, 'Eingabe-/Ausgabefehler')
the installer at 11/2017-1/2018 worked


#3

yeah the same installer worked for me too. is there a way to switch installers?


#4

Eggroll is working on it. It’s not ready yet though.


#5

Okay thanks…just one question…who is Eggroll? XD


#6

The maintainer of the script and creator of the Warframe Linux launcher. https://github.com/GloriousEggroll/warframe-linux

It should be good to install now. :slight_smile:


#7

Okay trying it now, thanks. Also if you see this thanks eggroll, for being awesome with this game!!!


#8

Good news it works now, thanks! XD


#9

Okay, new problem, im guessing with the updater:

it updates like normal, then stops with:

curl: (56) Recv faliure: Connection reset by peer

I’ve checked to see if curl is out dated, its not and im running the latest version, so what is going on?

I should mention that the updater did not work originally, so I tried a re-install and then this happened


#10

how i can chance the game language with this console launcher?


#11

The updater seems to get to 100% so, i think its now actually an issue with the game itself, the last two things it says are:

curl: (56) Recv faliure: Connection reset by peer
unlzma: (stdin): File format not recognised

this is it word for word, because I am unable to copy and paste this…someone please help!


#12

New bug now…:

doesn’t load, I ran it in a terminal and:

C:\Program Files\Warframe>title Warframe Linux Game Launcher

C:\Program Files\Warframe>cmd /C start /b /wait “” updater.exe
/home/craftygeek/Games/warframe/dosdevices/c:/Program Files/Warframe/updater.exe: line 4: xterm: command not found

I can’t edit the updater.exe or even open it so I have no idea what the unknown command is?
please help someone


#13

Install xterm: sudo apt install xterm


#14

yeah fixed it a while ago and forgot to say thx