Back to the main site

Warframe install script problem


#1

Hi, im trying to install warframe but it takes alot time and crashes.
Weird thing is that in debug i see “Process monitored bash, wine_setup_native” for each xaudio2 file in FAudio but with the same periods of time - 2min. seems like lutris is wainting for something. Also even without “-d” option i’m getting warning about killing thread and zombie process before chmodx operation on updater files (sh, exe) and wine_setup_native chmod x is working because they have execute rights.
Ubuntu 16.04
Lutris 0.4.23

Thank You for any help.
Marcin


#2

What is the crash like? Evolution error? Lutris/Wine crash? What is your Wine version? Have you tried the Steamplay Version? (note that it requires a connected controller or use of xboxdrv to no close itself within 5 minutes. Only steamplay version requires this)

What is your desktop environment? What is your graphics card? What drivers for it?


#3

I’m starting lutris from terminal and getting just:

Extracting archive: /home/user_name/Games/Windows/warframe/drive_c/Program Files/Warframe/warframe-linux-master.zip
Path = /home/user_name/Games/Windows/warframe/drive_c/Program Files/Warframe/warframe-linux-master.zip
Type = zip
Physical Size = 24531615
Comment = f28b0f1f4da0503e1adb51bcbf5736a4c1ca89bd
Everything is Ok                                          
Folders: 5
Files: 55
Size:       115382678
Compressed: 24531615
WARNING  2019-02-03 00:59:59,218 [thread]:Thread aborting now
WARNING  2019-02-03 00:59:59,219 [thread]:Zombie process detected, killing game process
WARNING  2019-02-03 01:00:14,232 [thread]:Thread aborting now
WARNING  2019-02-03 01:00:14,233 [thread]:Zombie process detected, killing game process
xaudio2_0: done <this after 2 min 
xaudio2_1: done <this after 2 min
xaudio2_2: done <this after 2 min
xaudio2_3: done <this after 2 min

No specific crash just this and it takes looong time after that lutris says game instalet but it isn’t.
-wine protonified 3.21-64bit
-rx560 open drivers with vulkan enabled from oibaf ppa
-ubuntu unity as a desktop

Thanks for any help.


#4

Sorry for the delay, I didn’t get properly notified.

So your game is now installed and you can press ‘play game’, right? Does a new terminal open when you press ‘play game’? It should open and start updating.

If not, open your System Monitor and look for two processes. One called updater.sh and, maybe, Warframe.x64.exe.

I got to a point where my updater.sh wasn’t showing on the screen, but it was updating things in the background nevertheless. If you ARE updating your game, it WILL take a long time.


#5

Sadly it stuck with xaudio as i wrote, i asume it should download warframe but it working with xaudio files (abnormaly long time) and then shows game installed but it’s not. The wine prefix is about 700MB so I’m sure warframe is not installed. On other computer the part with instaling xaudio files takes just seconds not ~40min (but on that computer i cant install fully because no vulcan support) . Thanks for reply


#6

Yes, that’s so odd… Installing xaudio and additional files do take a couple of settings. In the steamplay version, you add --firstrun to the run arguments if you want to (re)install those (to upgrade or fix an install).

You can either try putting that argument by right clicking the game on lutris>configure>game options>arguments; or you can reinstall the game on lutris (delete everything then try calling the install script again)

Just a quick random question: do you have winehq-staging/winehq-development installed in your system? Most WINE problems can be solved by this.

Do you NEED to use the protonified wine on your runner? The script seems to use the esync version.

If everything “crashes and burns”, the game STILL runs without DXVK. I remember playing it on Lutris/Steam for a while without realizing I had my vulkan packages broken, and performance was decent! (running on ryzen 2400g apu)