Warcraft 3 Reforged black screen without nothing else

Hi guys, I think I have a dxvk issue because when I´m launching W3R on battlenet there is a a window poping up but when I click on it there is no sound no pointer just a black screen …
Here is the log :
https://paste.ubuntu.com/p/rjhMvCvNsj/

Yes I ve already tried different wine versions, win7 in wine control, disabled enable several option, nothing fixed it. I have used commands to install dependencies required before too.

I am using Ubuntu 22 with intel GPU, I was able to used W3R on Ubuntu 20 , it is my only game bugging since I upgraded :S , as it was bugged I ve already re install everything : dependencies, battlenet and W3R.

How to fix it please ?

1 Like

by the way I´ve tried to do this commande again

sudo add-apt-repository ppa:kisak/kisak-mesa && sudo dpkg --add-architecture i386 && sudo apt update && sudo apt upgrade && sudo apt install libgl1-mesa-dri:i386 mesa-vulkan-drivers mesa-vulkan-drivers:i386

at the end it tells me there´s a GPG error because the public key isn´t avaible NO_PUBKEY 76F1A20FF987672F
and update was blocked because of a lack of security.

It could be the reason for my black screen problem right ?

mesa-vulkan-drivers est déjà la version la plus récente (22.2.0~kisak1~j).
libgl1-mesa-dri:i386 est déjà la version la plus récente (22.2.0~kisak1~j).
mesa-vulkan-drivers:i386 est déjà la version la plus récente (22.2.0~kisak1~j).

What I saw is that I don t have winehq but I have wine with lutris directly.

3 days on this bug I´m becoming crazy…

any idea please ? what about the error from dxva ? :´(

Hi there I’ve worked on it since 2 weeks, I finally re install ubuntu 22 to have a clean installation.
I have re install everything and I have this same bug again again…

What could I do please ?

(wrong ELF class: ELFCLASS64): ignored.
[1009/084134.925:ERROR:dxva_video_decode_accelerator_win.cc(1397)] DXVAVDA fatal error: could not LoadLibrary: msmpeg2vdec.dll: Module introuvable. (0x7E)
[1009/084134.930:ERROR:dxva_video_decode_accelerator_win.cc(1405)] DXVAVDA fatal error: could not LoadLibrary: msvproc.dll: Module introuvable. (0x7E)

Does someone have a clue please ?

Ok it finnaly worked disabling the original native drivers functions, I selected xorg instead, and windows 7 in wine settings and it worked, if it could help someone =)

1 Like

Hey was wondering how you disabled the native driver functions. I am getting the same dxva errors as you in overwatch 2. Im already set to xorg for my installation of ubuntu, just not well versed in this type of thing. Whenever you get around to it your help is greatly appreciated.

Hi there,

then when it´s opened you disable wayland, ctrl+s then ctrl+x to save it.
Finally if you have mesa and xorg drivers or whatever you´ve installed it should use it instead of native settings :wink: