Vkd3d proton

What version is lutris actually using of vkd3d. installing Lutris installs base vkd3d.

is it vkd3d-proton or vkd3d old version?

It actually doesn’t install vkd3d, vkd3d is listed as an optional dependency (definitely at least on Arch/Manjaro/etc).

It uses whichever version you have installed. vkd3d isn’t provided by Lutris the way DXVK is (you can look at this yourself by running ls ~/.local/share/lutris/runtime, you’ll see dxvk there, but no vkd3d.

I’m pretty sure the build of vkd3d that was used during the compilation of the wine build also matters, at least it does for TKG’s build system, which is what they’re using.

I’m almost certain they use vkd3d-proton for that part, though. Tannis does those builds, and I would be shocked if he wasn’t using vkd3d-proton. But again, you have to have vkd3d installed yourself for vkd3d to work with Lutris, and whichever version you have installed, that’s the version it’s using. Install vkd3d-proton and you’ll be using vkd3d-proton.

1 Like

I uninstalled vkd3d and vkd3d is still in Lutris and not gray out. Is that supposed to be like that even if I dont have vkd3d installed?
I’m on manjaro and it installed vkd3d with it. But I think its the old vkd3d.

Not it didn’t.

You can look at lutris’s dependencies by running pacman -Si lutris, it will show you that vkd3d and lib32-vkd3d are listed as optional dependencies, which means they DO NOT get installed as a result of installing lutris, you have to install them manually (unless another package installs them as a hard depencency). I’m literally looking at it right now.

Also, if Lutris had installed vkd3d as a dependency when you installed it, it wouldn’t have let you uninstall vkd3d like you said you just did, it would have said it was required by lutris. But it’s not.

Also, the toggle isn’t grayed out because it’s a combination toggle with DXVK. It doesn’t say “Enable vkd3d,” it says “Enable DXVK/VKD3D.” It’s not because DXVK is still an option. I’m literally looking at the Lutris version on Manjaro’s repos right now as well.

If you want to use the vkd3d-proton version, you can either install it manually, or use TK-Glitch’s PKGBUILD, which defaults to the proton fork. https://github.com/frogging-family/vkd3d-git

Clone that repo, run makepkg -si, and you’ll have vkd3d-proton and lib32-vkd3d-proton.

1 Like

My lutris has “Enable DXVK” and further down the option list “Enable VKD3D” they are separate. I did install vkd3d with lutris as an optional dependency and when uninstalling it , it did tell me lutris is depending on it but I removed it anyway. Thats why I am confused why it would still have it in the options menu without it greyed out.

My lutris has “Enable DXVK” and further down the option list “Enable VKD3D” they are separate.

Um… That would indicate you’re running an old version. Manjaro’s stable (and other) branch repos are showing, which is the same version I’m running, and it has the options combined.

But the reason it’s not greyed out is probably because of this:

With the Saturday release of Lutris, there is now a Direct3D 12 DLL based on VKD3D-Proton as part of the game manager’s DXVK runtime.

So like I said, the vkd3d build they’re building against is the new fork of vkd3d, otherwise known as vkd3d-proton. Note: This DOES NOT mean you do not need vkd3d, that only provides the .dll (the windows part), it does NOT provide the Linux libraries you need. Not whatsoever.

But again (I don’t think I can make it any clearer at this point), If you have the winehq (old) version of vkd3d installed, that’s what you’ll be using, if you have vkd3d-proton installed, then that’s what you’ll be using. You can’t use something that isn’t provided by Lutris and also isn’t installed on your system. If you want to use vkd3d-proton, You have to install vkd3d-proton.

it did tell me lutris is depending on it but I removed it anyway.

Again, that’s an optional dependency. If it were a HARD dependency, it literally would have cancelled the command. Look for yourself. Run:

sudo pacman -R cabextract

The command will say:

error: failed to prepare transaction (could not satisfy dependencies)
:: removing cabextract breaks dependency 'cabextract' required by lutris

(along with the same message for any other packages that depend on it).

Removing optional dependencies will still allow you to remove the package, it will just give you a warning message before it does it.

The reason it’s not greyed out is because either a) like I said, Lutris provides a d3d12.dll which is used by vkd3d and that’s what it uses to determine compatibility, or b) the current up-to-date version of Lutris no longer differentiates between DXVK and VKD3D in the configuration menu, and your lutris version just doesn’t know how to handle it since it’s supposed to only have one toggle. Either way, it’s irrelevant. Without vkd3d installed at all, vkd3d won’t run, and if you want to use vkd3d-proton, you need to install vkd3d-proton.

1 Like

ok I installed tkglich version now. My lutris is version 0.5.7-1. Straight from the pacman repo official and no AUR stuff. Checked.
So why is mine looking different from yours?

Is the 0.5.7-1 version not the version they have on github?

Run pacman -Q lutris. See if the output says:




Because I’m on on BOTH Arch and Manjaro, but I run Manjaro Unstable Branch, and it’s possible (though I would think unlikely) that Stable branch hasn’t gotten the minor update.

Either that, or you haven’t updated in about ~2 weeks, which is when that package was last updated (on both my installs, Manjaro and Arch).

If you really care that much (I don’t know why you would, it seriously doesn’t matter, and you’ll get the new version soon enough, your real issue is already solved), you can just switch to the Unstable branch just to update lutris, and then go back to the Stable branch. Or just download the package from the repos directly. You could use:


Which, now that I look at it, yeah. Manjaro Stable for some stupid reason still hasn’t updated to the newest Lutris version, it’s still on, not Even though is 2 weeks old, and was built over a month ago. But, usually Manjaro Stable branch waits for about 2-4 weeks before pushing updates, so I do understand, but anyway, there you go.

If you really don’t want to wait (I guarantee it will be a part of the next Stable update), download the package directly from the manjaro repo mirror link I posted, and run sudo pacman -U lutris- Otherwise, your main problem is already solved anyway.

1 Like

My version is 0.5.7-1.
I am up-to-date im sure and I think im on the stable branch, so I think I will just wait for the update, not in a hurry lol

Thanks a lot for the advice and help it helped clear up a lot. I didnt even know about tkglich version of the install for vkd3d and that it did it automatically. :slight_smile:

TKG does all.