Back to the main site

VC++ fails to install when installing The Sims 4

Hi guys trying to install The Sims 4 on Majaro gnome
with latest mesa drivers and all the wiki dependencies installed.
Origin installs without any issue but when trying to install the game it crasches with the message that
VC++ failed to install.

Thanks in advance for any idea.

Hey,

I have the same issue. Ive spent a while now trying to find a solution but none Ive found so far seem to work.

try this:

  1. download this archive: https://drive.google.com/file/d/1_u-YJjM-0rf7WmkcZNNhpNEf_BKw-P3m/view?usp=sharing
  2. replace the content of this folder:
    ~/.local/share/lutris/runners/wine/lutris-6.0-rc1-x86_64/
    by the content of the archive
  3. install The Sim 4
2 Likes

Thanks a lot it worked.

Hello, i’m trying it now. Just to be clear I do this before origin downloads the game right?

yes

Alright, thanks, it worked! Should I avoid updating etc.?

no need to avoid something, have good game!

okay, thank you!

Just another confirmation; this solved the same issue for me too. Does this mean that ideally the installer script needs to be updated?

Nope, it’s the Lutris WIne that needs to be updated. Lutris WIne build 6 will soon be available.