Vanquish - Black Window

I’ve tried running the game w/ staging-3.12-x86_64, staging-3.10-x86_64, and 3.0.2; the result is the same: black windowed screen which stops responding after ~10 seconds. Tried enabling / disabling Lutris Runtime, passing -windowed / -fullscreen / -sw, none of which had any effect. It would be extremely helpful if when giving a game a rating (as this game has a ‘Platinum’ rating in Lutris), the wine version tested was indicated (as it is on WineHQ: Vanquish). btw, phenomenal work on Lutris. Debug below.

Debian 4.9.110-1
Nvidia 390.67

DEBUG 2018-07-23 21:53:05,024 [system]:Executing pgrep Steam.exe$
INFO 2018-07-23 21:53:05,059 [runner]:Runtime disabled by system configuration
DEBUG 2018-07-23 21:53:05,060 [game]:Launching Vanquish: {‘env’: {‘WINE’: ‘/home/dymax/.local/share/lutris/runners/wine/staging-3.12-x86_64/bin/wine’, ‘WINEDEBUG’: ‘-all’, ‘WINEPREFIX’: ‘/home/dymax/.local/share/lutris/runners/winesteam/prefix64’, ‘DRI_PRIME’: ‘0’, ‘WINEARCH’: ‘win64’}, ‘command’: [’/home/dymax/.local/share/lutris/runners/wine/staging-3.12-x86_64/bin/wine’, ‘/home/dymax/.local/share/lutris/runners/winesteam/prefix64/drive_c/Program Files (x86)/Steam/Steam.exe’, ‘-no-cef-sandbox’, ‘steam://rungameid/460810’]}
DEBUG 2018-07-23 21:53:05,061 [thread]:Command env: WINEDEBUG="-all" SDL_VIDEO_FULLSCREEN_DISPLAY=“0” WINEARCH=“win64” WINE="/home/dymax/.local/share/lutris/runners/wine/staging-3.12-x86_64/bin/wine" DRI_PRIME=“0” WINEPREFIX="/home/dymax/.local/share/lutris/runners/winesteam/prefix64"
DEBUG 2018-07-23 21:53:05,061 [thread]:Running command: “/home/dymax/.local/share/lutris/runners/wine/staging-3.12-x86_64/bin/wine” “/home/dymax/.local/share/lutris/runners/winesteam/prefix64/drive_c/Program Files (x86)/Steam/Steam.exe” “-no-cef-sandbox” “steam://rungameid/460810”
DEBUG 2018-07-23 21:53:05,062 [thread]:Storing environment variable WINEDEBUG to -all
DEBUG 2018-07-23 21:53:05,062 [thread]:Storing environment variable SDL_VIDEO_FULLSCREEN_DISPLAY to 0
DEBUG 2018-07-23 21:53:05,062 [thread]:Storing environment variable WINEARCH to win64
DEBUG 2018-07-23 21:53:05,062 [thread]:Storing environment variable WINE to /home/dymax/.local/share/lutris/runners/wine/staging-3.12-x86_64/bin/wine
DEBUG 2018-07-23 21:53:05,062 [thread]:Storing environment variable DRI_PRIME to 0
DEBUG 2018-07-23 21:53:05,063 [thread]:Storing environment variable WINEPREFIX to /home/dymax/.local/share/lutris/runners/winesteam/prefix64
wine: cannot find L"C:\windows\system32\winemenubuilder.exe"
DEBUG 2018-07-23 21:53:07,206 [thread]:Processes excluded: Steam.exe (2062:S), Steam.exe (2062:S), wineserver (2065:S)
[0723/] Crash reporting enabled for process: browser
[0723/] WSALookupServiceBegin failed with: 8
[0723/] Lost UI shared context.
DEBUG 2018-07-23 21:53:09,225 [thread]:Start process monitoring
DEBUG 2018-07-23 21:53:09,226 [thread]:Processes monitored: gldriverquery64 (2184:R)
DEBUG 2018-07-23 21:53:09,226 [thread]:Processes excluded: Steam.exe (2062:S), steamwebhelper. (2123:S), Steam.exe (2062:S), wineserver (2065:S), steamwebhelper. (2116:S)
DEBUG 2018-07-23 21:53:11,226 [thread]:Processes monitored: none
DEBUG 2018-07-23 21:53:11,226 [thread]:Processes excluded: Steam.exe (2062:S), steamwebhelper. (2123:S), Steam.exe (2062:S), wineserver (2065:R), steamwebhelper. (2116:S)
DEBUG 2018-07-23 21:53:13,243 [thread]:Processes excluded: Steam.exe (2062:S), steamwebhelper. (2123:S), Steam.exe (2062:S), wineserver (2065:S), steamwebhelper. (2207:S), steamwebhelper. (2116:S), steamwebhelper. (2203:S)
[0723/] Crash reporting enabled for process: renderer
[0723/] Crash reporting enabled for process: gpu-process
DEBUG 2018-07-23 21:53:15,249 [thread]:Processes excluded: Steam.exe (2062:S), steamwebhelper. (2123:S), Steam.exe (2062:R), wineserver (2065:R), steamwebhelper. (2207:S), steamwebhelper. (2116:S), steamwebhelper. (2203:S)
DEBUG 2018-07-23 21:53:17,256 [thread]:Processes monitored: Vanquish.exe (2259:S)
DEBUG 2018-07-23 21:53:17,257 [thread]:Processes excluded: Steam.exe (2062:R), steamwebhelper. (2123:S), Steam.exe (2062:R), wineserver (2065:S), steamwebhelper. (2207:S), steamwebhelper. (2116:S), steamwebhelper. (2203:S)
DEBUG 2018-07-23 21:53:19,248 [thread]:Processes monitored: Vanquish.exe (2259:R)

  • Do you have wine installed in your whole system as well? (winehq-staging)
  • Can you play other wineSteam games? Do you have them currently installed?
  • Is DXVK on?

My two generic advices from your information atm are:

  • Consider updating your graphics card driver. 396 has shown to work with the new NVidia 1000 series (1050 ti, 1060 ti, 1080 ti from people I’ve talked recently)
  • The game has a platinum rating on Lutris and the only thing it does is get the appid. That’s a perfect game to install a standalone WINEPREFIX to try it yourself!

In a terminal, call wine for a Steam install. Download the Windows Steam Installer beforehand and, in its download folder:

WINEPREFIX=/path/you/want/to/install wine SteamSetup.exe

You may log into steam and then leave. Then do

WINEPREFIX=/path/you/want/to/install winecfg

and check if the CSMT box under the staging tab is marked. The guy from AppDB mentioned it could be a problem.

Next you will download the game and try it. If it REALLY is Platinum, that’s all it need to run: installing steam and downloading the game.

If this does not run, it would be good to ask to lower the rating on that install script.

wine-stable/stable,now 3.0.2~stretch amd64 [installed,automatic]
wine-stable-amd64/stable,now 3.0.2~stretch amd64 [installed,automatic]
wine-stable-i386/stable,now 3.0.2~stretch i386 [installed,automatic]
winehq-stable/stable,now 3.0.2~stretch amd64 [installed]
winetricks/stable,stable,now 0.0+20170101-1 all [installed]

Yes, I can play other wineSteam games.
DXKV is not on.


My card is a 970. 390.67 is the latest version on the Debian repos (specifically, stretch backports). This could very well be a problem, but I am not encountering issues with other games (e.g. Thumper, Binary Domain)

Last night I installed the game via wineSteam (outside of Lutris) and the result was the same: windowed, black screen that locks up after ~ 10 seconds.

Thank you for your assistance so far.

Remove wine from your system and install the winehq-staging version. There’s a small possibility staging dependencies are slightly different from stable (because staging is at 3.13 and stable is at 3.0.2).

  • How are the other games you can play on wineSteam?
  • Are they comparable in graphics engine?
  • Do they use directx9 or directx11?
  • Are they from about the same period of release (e.g.: 2015 and 2017)?

The screen being black and locking up seems to mean the game is trying to load the adequate libraries and failing somewhere in the end.

Try updating your wine to winehq-staging, update your wineprefix

WINEPREFIX=/path/you/created winecfg

run again and see if there’s any difference.

The last step right now would be checking on NVidia’s page what’s the last supported driver for your graphics card. If it’s not 390.67, I would recommend looking for an updated repository and install that version. I know about Ubuntu/Linux Mint repositories, but each distribution should have them easily available.

p.s.: try enabling DXVK on lutris and see if the exact same problem happens.
EDIT: p.s2.: I noticed you have a message mentioning DRI_PRIME is set to 0. This means the game is tring to use your integrated graphics card. Try setting and environment variable on lutris DRI_PRIME to 1.

If you want to use your new steam prefix, put “env DRI_PRIME=1” to the beginning of the command starting Steam

Nvidia 390.67 is the most recent version for Debian; anything higher is unstable/testing/experimental. Not using the backport, the repos push 384.xx.

Regarding PRIME, I don’t own an integrated graphics card or second card.

$ xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x1b9 cap: 0x1, Source Output crtcs: 4 outputs: 6 associated providers: 0 name:NVIDIA-0

But I did try it in staging 3.13 and the result was the same. Additionally, setting the environmental variable specifically for the games settings, the game continued to load with DRI_PRIME=0.

I appreciate your assistance so far. I’ll try your other suggestions.

edit: I’m going to update my kernel and drivers and proceed from there.

I really suggest trying one of those “experimental” drivers and rolling back if it doesn’t work. What I did ask was if you had the last version supported by your graphics card. You can check that information in NVidia’s website. If it says the last version is 396.x, for example, you should try an update. If it doesn’t and 390.67 is, indeed, the highest your card is supported, stay there and try other solutions.

You haven’t mentioned trying DXVK on yet. Another reason to update your drivers is that DXVK above 0.52 usually requires such beta/development drivers.

Does the game have x32 and x64 binaries? Some games have -x32 and -x64 flags you can use to switch between versions. You put those on Set Launch Options on Steam, right clicking your game on the list and going to its options.

Heads up: I was playing a Magic Arena right now and if I put Anti-aliasing on “High”, the game would go completely black. Putting it on “Low” made everything draw correctly. I’d prefer to turn it off, but in this specific game, I can’t.

See if you can go through options (probably through an .ini file) if things don’t work.