Back to the main site

Vampire the Masquerade Bloodlines and some others scripts

I created a new installer, with support to select the installed mods, and this script also downloads and installs the latest version of the Unofficial Patch if wanted.

I’m submitting to moderation, and since this is a bit complicated script, I’m posting this topic to answer the questions about the script.

these are the scripts to download the unofficial patch, and the loader to select mods.

I submitted some others scripts waiting for moderation

It’s seems that new games have priority, but I hope these can be approved as well.

Hello, I validated the the first three.
But I tried Volgarr and it doesn’t work.
Is it a free rom? Without copyright?
Freely distributable?
Why do you upload the flycast core in the script, you can already download it from retroarch Lutris runner.

Yes, the Dreamcast version is free, you can download from the official site

http://www.volgarrtheviking.com,

but is difficult to find it,

http://www.volgarrtheviking.com/dreamcast/

Some more information
https://volgarr.rkd.zone/readme.html

the flycast is downloaded from the libretro site, is the same location where the retroarch download it, I only put it on the script to make the game work without the user intervention.

I will test the script again to find out the errors.

Volgarr script work here, it is installed without problems, no error when running lutris with debug flag activated. The only issue is that, after installed, 2 entries for volgarr was created.

Can you execute the lutris -d before your test and send your output?

and can you check the script from the first post, vampire bloodlines?

Thanks for the help with the others scripts

Nice work Welblade, your scripts install are well explained and sources available on gitlab, it’s easier for me to validate them.
Vampire Bloodlines checked.

So for Volgarr, copyright seems ok, I tried again to install it without success:

2020-04-04 10:58:06,134: GET https://lutris.net/api/installers/volgarr-the-viking-sega-dreamcast-flyca
2020-04-04 10:58:08,684: Using cache path /tmp/lutris-cache/volgarr-the-viking/file1
2020-04-04 10:58:08,684: Using cache path /tmp/lutris-cache/volgarr-the-viking/file2
2020-04-04 10:58:10,426: Required runners: [<lutris.runners.libretro.libretro object at 0x7fee2cba6a90>]
2020-04-04 10:58:10,443: Runner %s needs to be installed
2020-04-04 10:58:10,443: Installing libretro
2020-04-04 10:58:10,445: Installing libretro (version=flycast, downloader=<bound method InstallerWindow.start_download of <installerwindow.InstallerWindow object at 0x7fee2994ad40 (lutris+gui+installerwindow+InstallerWindow at 0x3102b40)>>, callback=<bound method ScriptInterpreter.install_runners of <lutris.installer.interpreter.ScriptInterpreter object at 0x7fee29142b20>>)
2020-04-04 10:58:10,445: Getting runner information for libretro (version: flycast)
2020-04-04 10:58:10,446: GET https://lutris.net/api/runners/libretro
2020-04-04 10:58:10,535: Failed to retrieve libretro (flycast) information
2020-04-04 10:58:10,535: Failed to retrieve libretro (flycast) information
None

I just obtain this error message in a window:

“I only put it on the script to make the game work without the user intervention”
Good idea, it’s Lutris objective, just click “install” and “play”, no more hourly tweaks.

It’s seems that lutris is trying to download the flycast by it self, my lutris version don’t try to do that. May it is because retroarch is already installed, I will try to remove it first and see what will happen.

edit:
Confirmed, if lutris don’t have the retroarch runner already installed, it will download the runner and try to download the core from lutris server, but flycast don’t exist in the lutris server.
Lutris don’t try to download the core if the runner is installed.

I will test some options to make this work

Flycast is the rebranded reicast, so the script now is using reicast as core, but it will download the latest flycast to replace the extremely outdated reicast, and it works just fine. :slightly_smiling_face:

but flycast don’t exist in the lutris server.

So for the moment please made it simplier, just let reicast core and you will update your script when Lutris team will update Retroarch and all their cores to a more recent version, ok?

ok

Can you make request to update the cores and include flycast? As moderator, it might be easier to contact the devs.

Reicast is rebranded over a year ago, and the current flycast have much better performance.

And reicast is no showed in the lutris list of cores anymore

Please open an issue on Github, it will be more efficient to ask Lutris dev team to update retroarch and their cores.
Anyway I tried again your script and it still doesn’t work.
Did you try it on a new install? on another computer or virtual machine (virtualbox, gnome-boxes…) with a fresh Linux distribution installed?
I installed a fresh Ubuntu 18.04 and others distro in gnome-boxes to test my scripts and I have regurlarly some surprises (bad).

`files:

the script now, only copy the iso and install the reicast from lutris server, and works here.

I tested in my own machine, I will do as you, and install a fresh vm to test it.

I reported an issue on Lutris Github section:

Great! :slightly_smiling_face:

Thanks, this will make things easier.

Will all the cores from here be updated?

https://lutris.net/files/runners/

The code is already changed and pushed to digital occean. But is the buildbot working?
The last update is from november of 2019.

For the moment changes are not merged:

Retroarch was updated, but flycast is not added, and the other cores remain outdated.

I tought that the buildbot would automatically update them.

Hello Welblade, I tried to install your volgarr the viking script installer and it installed ok with flycast core, could you try again?

It’s working, finally they updated some of the cores. :slightly_smiling_face:

The only problem left is that the script is not installing the core if the libretro runner is already installed.