Back to the main site

Uplay will not start up online

As the title states, Uplay cannot seem to start up online. It starts up offline just fine.

I just reinstalled Arch Linux onto an M2, and I copied my old Manjaro home to a brand new HDD. It has my previous install of Lutris and all the other stuff. I reinstalled from the Lutris website, and Epic Games, Blizzard, and Origin all work fine. Uplay though, is my issue.

Here is my lutris -d output: https://pastebin.com/e5tE7ihH
I tried doing lutris --submit-issue, but that just wants me to save it somewhere. So screw that, I’m posting here.

I’m guessing something got jumbled in translation. If so, I’m completely fine removing and reinstalling Uplay, but I’ll have to look into that. It was the final option I booted up and was kind of shocked it didn’t just work like the others did.

I have the same problem : Impossible to connect online…
Edit: The problem is solved with the installation of the package “wine32”.

Hi, I’m on Arch and having a similar problem. Can you explain what you mean by package wine32? Arch doesn’t have that package so I’m not sure what I’m missing. Thanks!

I was able to solve this by installing lib32-gnutls. Thank you.

6 Likes

In my xubuntu 20.04, the package is in the universe depot :
wine32/focal,now 5.0-3ubuntu1 i386 [installé]
Windows API implementation - 32-bit binary loader

You can see more information here :
https://ubuntu.pkgs.org/20.04/ubuntu-universe-i386/wine32_5.0-3ubuntu1_i386.deb.html

Thank’s!!!

Thank u
I am also having the same problem with uplay

i will try that

Worked for me!

Arch Linux/ Manjaro User here

I fixed it by installing these

sudo pacman -S --needed wine-staging giflib lib32-giflib libpng lib32-libpng libldap lib32-libldap gnutls lib32-gnutls \
mpg123 lib32-mpg123 openal lib32-openal v4l-utils lib32-v4l-utils libpulse lib32-libpulse libgpg-error \
lib32-libgpg-error alsa-plugins lib32-alsa-plugins alsa-lib lib32-alsa-lib libjpeg-turbo lib32-libjpeg-turbo \
sqlite lib32-sqlite libxcomposite lib32-libxcomposite libxinerama lib32-libgcrypt libgcrypt lib32-libxinerama \
ncurses lib32-ncurses opencl-icd-loader lib32-opencl-icd-loader libxslt lib32-libxslt libva lib32-libva gtk3 \
lib32-gtk3 gst-plugins-base-libs lib32-gst-plugins-base-libs vulkan-icd-loader lib32-vulkan-icd-loader

source from here : https://github.com/lutris/docs/blob/master/WineDependencies.md