Back to the main site

Uplay - https://lutris.net/games/uplay/


#1

I managed to get it installed. I had to edit FF’s about:config, to allow me to tell it to use lutris to associate the installer. Every time I run Uplay, it quits before I can type in my login details. It runs for a few seconds then quits.


#2

Here is a copy of Uplay’s last log.

[1218/152103.776:ERROR:network_change_notifier_win.cc(157)] WSALookupServiceBegin failed with: 8
[1218/152104.034:ERROR:viz_main_impl.cc(201)] Exiting GPU process due to errors during initialization
[1218/152104.306:ERROR:viz_main_impl.cc(201)] Exiting GPU process due to errors during initialization
[1218/152104.321:ERROR:browser_gpu_channel_host_factory.cc(119)] Failed to launch GPU process.
[1218/152104.321:ERROR:gpu_process_transport_factory.cc(1026)] Lost UI shared context.


#3

I found a temporary work around by disabling the Process monitor. Uplay works now. Please let me know when you get this fixed so I can turn it back on.


#4

I am playing Anno 2070 I can’t activate my code. This is what the product activation window looks like.
Did the Lutris Uplay installer miss some fonts or something?


#5

Hi, I have the same issue when Uplay runs for a few seconds and then quits. I tried the workaround of disabling the Process monitor and it works.
I’m on Linux Mint 19. I installed Uplay via the default script on the lutris website.
I use an Nvidia gtx960 with drivers 390.77.
Here’s a screenshot of my Runner options even though I’ve already tried different wine versions and DXVK versions:

If someone has a fix please let us know. We’re probably not the only ones with this issue.
Thanks :slight_smile:


#6

When I try to launch World in Conflict from Uplay, I can also see a font issue and if I click the “Start game” button, I see a black screen then the game crashes.

EDIT: To solve the game crashing, I just had to select DXVK 0.61.


#7

If I launch Uplay without disabling the Process monitor option, here is what I get:

wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
    DEBUG    2018-12-22 22:07:43,281 [thread]:Start process monitoring
    DEBUG    2018-12-22 22:07:43,282 [thread]:Processes monitored: Uplay.exe (3382:Z)
    DEBUG    2018-12-22 22:07:43,282 [thread]:Processes excluded: wineserver (3385:S)
    [1222/220744.724:ERROR:network_change_notifier_win.cc(157)] WSALookupServiceBegin failed with: 8
    [1222/220744.984:ERROR:viz_main_impl.cc(201)] Exiting GPU process due to errors during initialization
    DEBUG    2018-12-22 22:07:45,320 [thread]:Processes monitored: none
    [1222/220745.263:ERROR:viz_main_impl.cc(201)] Exiting GPU process due to errors during initialization
    DEBUG    2018-12-22 22:07:47,340 [thread]:Processes excluded: wineserver (3385:R)
    DEBUG    2018-12-22 22:07:49,284 [thread]:Processes excluded: wineserver (3385:S)
    DEBUG    2018-12-22 22:07:49,285 [thread]:Thread aborting in 3 cycle
    DEBUG    2018-12-22 22:07:51,288 [thread]:Thread aborting in 2 cycle
    DEBUG    2018-12-22 22:07:53,285 [thread]:Thread aborting in 1 cycle
    WARNING  2018-12-22 22:07:55,289 [thread]:Thread aborting now
    DEBUG    2018-12-22 22:07:55,289 [thread]:Detaching logger
    DEBUG    2018-12-22 22:07:55,497 [wine]:Killing all wine processes: ['/opt/wine-staging/bin/wineserver', '-k']
    DEBUG    2018-12-22 22:07:55,498 [wine]:	Wine prefix: /home/ronin/Games/uplay
    DEBUG    2018-12-22 22:07:55,498 [wine]:	Wine arch: win64
    DEBUG    2018-12-22 22:07:55,498 [wine]:	Initial pids: {'3385'}
    DEBUG    2018-12-22 22:07:55,552 [wine]:Waiting for wine processes to terminate
    DEBUG    2018-12-22 22:07:55,553 [thread]:Restoring environment
    DEBUG    2018-12-22 22:07:55,553 [thread]:1 processes are still active
    DEBUG    2018-12-22 22:07:57,078 [game]:Game thread stopped
    DEBUG    2018-12-22 22:07:57,079 [game]:Game thread still running, stopping it (state: running)
    DEBUG    2018-12-22 22:07:57,079 [thread]:Detaching logger
    DEBUG    2018-12-22 22:07:57,080 [game]:Uplay stopped at Sat, 22 Dec 2018 22:07:57
    /usr/lib/python3/dist-packages/lutris/thread.py:248: Warning: Source ID 2837 was not found when attempting to remove it
      GLib.source_remove(self.stdout_monitor)
    DEBUG    2018-12-22 22:07:57,264 [wine]:Killing all wine processes: ['/opt/wine-staging/bin/wineserver', '-k']
    DEBUG    2018-12-22 22:07:57,265 [wine]:	Wine prefix: /home/ronin/Games/uplay
    DEBUG    2018-12-22 22:07:57,265 [wine]:	Wine arch: win64
    DEBUG    2018-12-22 22:07:57,270 [wine]:Waiting for wine processes to terminate
    DEBUG    2018-12-22 22:07:57,271 [thread]:Restoring environment
    DEBUG    2018-12-22 22:07:57,271 [thread]:Killing all remaining processes

#8

Looks very similar to what I get.


#9

could enybody tell me how to disable Process monitor?


#10

It’s under advanced properties.


#11

Not anymore for some reason

I am on Arch and have an up to date version so I cannot do this.


#12