Uplay Far Cry 5 is not starting

Hi guys,
first I have to mention I already tried to search something info about this issue, but with no success.

I installed Lutris and all dependencies, also UPlay which is working correctly, installation of Far Cry 5 is correct as well, but if I want to play only small window with info about synchronization game and so on appears and then nothing. I also tried to install Rayman Legends and it seems to work. I am able to play. But FC5 don’t.

In attachments are outputs from neofetch and glxinfo and whole log from run UPlay to nothing happenning after run FC5.


I also tried to turn off overlay in UPlay and turn off nvapi.

Nothing more I am able to do for now. Please help. :slight_smile:

/// START EDIT 1 ///
Assassin’s Creed Origins isn’t running as well.

Wine version: tkg-4.1-x86_64
DVXK: 0.96
another versions tested as well.
// END EDIT 1 ///

Neither game works on Wine atm. FC5 does but only with a crack and it still has problems with input. E.g. you can’t steer any vehicles.

Not even a cracked AC Origins works.

So, I guess the best way still remains installing Windows to another HDD and play games from that. What I actually did before a while. :slight_smile: