Unable to sign in league of legends lutris

Hello, so its been three days that i am unable to login to the riot client of legend of legends with a message saying : ‘Sorry we’re having trouble signing you in right now’. It worked perfectly before and even when i use another account the same issue appear (even fake accounts like abcd999hhdd). i have tried deleting and redownloading the game many times as well as lutris and wine and nothing fixes it.

I am using the latest version of arch linux lutris and wine. Any idea ?


Bump. I`m having the same problem in arch in like 4 days no solution yet, already tried changing name server, ip and others.

1 Like

dont speak inglish.
esto funciono para mi:
sudo pamac install lib32-gnutls

1 Like

@bal1234 not in my house rn can you test it?

Having the same problem. I am using arch (btw) and installed lib32-gnutls. But it did nothing for me. Still cant sign in.

Thanks, installing lib32-gnutls fixed it for me

@mrk3in Gracias, worked for me too.

Worked for me, thanks a lot!

after killing riotclient process and than starting again fixed it finally