Unable to run install script for league of legends

The install for league in directx 9 is currently down I think, should I just try the opengl one?
@GloriousEggroll said that directx is much better than opengl at the moment, but the install link is not working currently.
Its kind of embarrassing to say but I remade the linux bootable because I was getting broken packages bugs (I didn’t know I had to enable i356 or whatever that made 32 bit possible on my 64 bit…I’m so dumb). I had league installed but had basically factory reset sooo xD

I think Directx one should be up soon, or something messed up on my hardware, but is opengl worth a shot now? I looked up opengl on google and apparently it works better on most games on most computers.

But I happen to only play league of legends. All I want is pretty manageable fps (40-60) I dont care about effects quality (maybe except medium environment quality).

My chromebook is running Intel® Celeron® Processor 3205U https://ark.intel.com/products/84809/Intel-Celeron-Processor-3205U-2M-Cache-1_50-GHz (I think, lol) and has 4GB of ram (never gonna run out of those).

However, my cpu doesn’t have a dedicated graphics card or anything so that’s whats worrying me. When I’m just running Lubuntu it freezes for few moments when I have many things running at once, especially with lutris running (i’m not even run anything on it lol, but my cpu only a dual core, whatever), but setting the cpu gov to performance have helped a lot (extra question, cpufreq-info says my cpu is running at 1.70 GHertz, but its maximum is 1.50. I have not changed anything that may overclock my cpu, and think that’s whats temporarily throttling my cpu sometimes (causes extensive freezes).) .

Would OpenGL work better for performance (less freezes/crashes) or DirectX? What can improve my cpu performance without burning it (my chromebook has a fan apparently btw)?

Thanks and much love <3
I know I’m asking a lot of questions here… but I’m a newbie (to linux and all complicated installing packages and dependencies), and would like to know from you experts here. Google searches usually have limits, and are pretty vague for novices. Thanks again to all of you guys.

1 Like

Go ahead and use the opengl one. I found a fix for amd/intel on opengl today so fonts dont render blocky any more. It also doesnt suffer from fps degredation

Hey I just tried using the OpenGL one and everytime I try and start a game I get an “unknown DirectX error.” but I made sure that x3d_platform =1. I even tried a removing league completely and installing.

EDIT: I just noticed that in the wine config windows version was set to windows 2008. Changing it to XP didn’t fix my problem though.

EDIT2: I tried installing directx9 through winetricks and deleting the overides but I still get the error. running 4.13.5 kernel and a RX480

you shouldn’t need to change anything after you run the install script. the install script sets opengl mode automatically during installation. you will need to make sure you have all wine dependencies installed

EDIT1: DX9 script problem should be resolved now

EDIT2 : I just checked the script on a fresh ubuntu install via VM and came across the same problem, working on a resolution now. I also noticed the config wasn’t being written properly. Check Config/game.cfg [General] section

if it looks like this:
-e [General]

change it to this:

You’re missing wine dependencies. On ubuntu sudo apt-get install wine-development

Running Solus 3 and I tried installing wine-dev and wine32-dev still get the error. Do you have any idea what dependency it might be?

I will retry the DX9 version, but for now the OGL script does not work for Solus3 users. Whenever I try to start a game I get “An unknown DirectX error has occured” error popup and it opens the client again. otherwise the client works fine. I don’t know why it is not changing to OGL mode.

EDIT: SO the DX9 version doesn’t work for me anymore. The client works fine but when I go to start a game it bugsplats and sends me back to the client. I noticed my wine config says Windows 2008 R2, but changing this to windows XP doesn’t fix the problem.

EDIT2: This doesn’t make any sense because it worked 9 days ago when you updated the DX9 for the first time. I am running kernel 4.13 so maybe that broke it?

kernel has nothing to do with it. its dependencies. give me some time to run a vm with solus and ill get back to you

also - can you try disabling the lutris runtime?

right click lol in lutris->configure->system
disable lutris runtime

you may need advanced options on at the bottom

So disabling the lutris runtime fixes the issues for both the DX9 and OGL installs in Solus3.

Feels good to spend all day searching for dependencies and testing things to fix it by checking a checkbox.

cool. I’ll disable them in the scripts, You do still need the dependencies. the problem is it was probably trying to use dependencies found in lutris runtime files

Good to see all this work on the League of Legends install script :slight_smile:
So, what should we use actually? DirectX or OpenGL?

I would say opengl as it doesn’t have the fps degredation bug. I am not sure if gallium 9 has the bug.