Back to the main site

Unable to install Logitech G Hub - Install does not begin / start

I just installed Lutris, not primarily for playing games ( I have a Windows machine for that ), but for using Logitech G Hub for using proper macros on my Logitech G600 on my development device.

I installed Lutris and Wine - fresh install for both and in that order (first lutris, then wine, none of them showed any errors I think).

I am not able to install Logitech G Hub from my Lutris library - nothing happens when I click the install button.

I tried running Lutris in debug mode and got the following output -

lutris -d
2021-11-10 11:36:48,031: Starting Lutris 0.5.9.1
2021-11-10 11:36:48,055: No cores found
2021-11-10 11:36:49,699: Failed to read content length on response from https://api.github.com/repos/lutris/dxvk/releases
2021-11-10 11:36:50,108: Failed to read content length on response from https://api.github.com/repos/lutris/dxvk-nvapi/releases
2021-11-10 11:36:50,928: Startup complete
INFO     2021-11-10 11:36:50,930 [startup.check_driver:61]:Running Intel Mesa driver 21.0.3 on Mesa Intel(R) Xe Graphics (TGL GT2) (0x9a49)
INFO     2021-11-10 11:36:50,930 [startup.check_driver:73]:GPU: 8086:9A49 1043:15CC (i915 drivers)
MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

DEBUG    2021-11-10 11:36:51,116 [lutriswindow.update_store:451]:Showing 1 games
DEBUG    2021-11-10 11:36:58,540 [__init__.fetch_script:22]:Fetching installer https://lutris.net/api/installers/logitech-g-hub
DEBUG    2021-11-10 11:36:58,540 [http.get:81]:GET https://lutris.net/api/installers/logitech-g-hub
DEBUG    2021-11-10 11:36:59,119 [application.on_game_install:515]:Should generate automagical installer here but....
DEBUG    2021-11-10 11:36:59,119 [application.on_game_install:516]:Wait? how did you get here?
DEBUG    2021-11-10 11:46:17,276 [__init__.fetch_script:22]:Fetching installer https://lutris.net/api/installers/logitech-g-hub
DEBUG    2021-11-10 11:46:17,277 [http.get:81]:GET https://lutris.net/api/installers/logitech-g-hub
DEBUG    2021-11-10 11:46:17,916 [application.on_game_install:515]:Should generate automagical installer here but....
DEBUG    2021-11-10 11:46:17,916 [application.on_game_install:516]:Wait? how did you get here?
INFO     2021-11-10 11:47:08,660 [application.do_shutdown:631]:Shutting down Lutris

System Info -

Ubuntu 20.04.3 LTS
OpenSSL version - OpenSSL 1.1.1f 31 Mar 2020
Location - India
Dynamic IP output on running ping to lutris.net -

ping lutris.net
PING lutris.net(2606:4700:90cc:5cf5:a564:107:1594:d6bc (2606:4700:90cc:5cf5:a564:107:1594:d6bc)) 56 data bytes
64 bytes from 2606:4700:90cc:5cf5:a564:107:1594:d6bc (2606:4700:90cc:5cf5:a564:107:1594:d6bc): icmp_seq=1 ttl=57 time=228 ms
64 bytes from 2606:4700:90cc:5cf5:a564:107:1594:d6bc (2606:4700:90cc:5cf5:a564:107:1594:d6bc): icmp_seq=2 ttl=57 time=251 ms
64 bytes from 2606:4700:90cc:5cf5:a564:107:1594:d6bc (2606:4700:90cc:5cf5:a564:107:1594:d6bc): icmp_seq=3 ttl=57 time=166 ms
64 bytes from 2606:4700:90cc:5cf5:a564:107:1594:d6bc (2606:4700:90cc:5cf5:a564:107:1594:d6bc): icmp_seq=4 ttl=57 time=194 ms

On specifically running IPv4 command for ping -

ping lutris.net -4
PING lutris.net (172.67.189.19) 56(84) bytes of data.
64 bytes from 172.67.189.19 (172.67.189.19): icmp_seq=1 ttl=53 time=34.1 ms
64 bytes from 172.67.189.19 (172.67.189.19): icmp_seq=2 ttl=53 time=29.2 ms
64 bytes from 172.67.189.19 (172.67.189.19): icmp_seq=3 ttl=53 time=30.8 ms
64 bytes from 172.67.189.19 (172.67.189.19): icmp_seq=4 ttl=53 time=29.9 ms
64 bytes from 172.67.189.19 (172.67.189.19): icmp_seq=5 ttl=53 time=28.1 ms
64 bytes from 172.67.189.19 (172.67.189.19): icmp_seq=6 ttl=53 time=29.0 ms
64 bytes from 172.67.189.19 (172.67.189.19): icmp_seq=7 ttl=53 time=30.2 ms
^C
--- lutris.net ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 6007ms
rtt min/avg/max/mdev = 28.139/30.196/34.106/1.787 ms

I can share any further info required.
I hope this can be solved, I’m not very new to linux, but haven’t been able to move away from Windows because of compatibility issues of programs and features with linux.

1 Like

Interesting, checking lutris.nets unpublished installers shows that GHub exists as a ‘game’, but has no installers for it. Which is why you’re experiencing this issue. Don’t know what happened to the original install script.

Hi, sorry for the late reply, I was not in town. So the original install script is not available. Can anything be done about it? Anywhere I can find it?