Unable to install League of Legends on Manjaro 16.06.1

Hi Lutris Team,

Here is the process I followed when getting everything installed. First I setup my account and installed League of Legends on one of my secondary laptops, running Ubuntu Mate 16.04.1, and everything worked flawlessly.

After doing that and confirming the install worked I began the process of getting Lutris installed on my Manjaro main box. Unfortunately, when I clicked on League of Legends I would get the League of Legends splash screen and it begins loading then I get a message in the Lutris client that the game has quite. Am I missing something or is there some kind of weirdness with my account / library being connected.

I have since tried to remove Lutris from Manjaro and removed its dependecies and reinstalling and still no go. Any ideas?




Are you using the Wine build that is specified for LoL or the Wine version installed on your system? I’ve received a bug report about the system wine which will be fixed soon.

Anyway, only the patched version should be used since vanilla wine (or even wine staging) will crash when you open the in-game shop.

Hi strider,

Been out of town and just got back in. So I tried this with the current stable release of wine as well as the staging versions you mentioned specific to League of Legends as well. I am actually running the latest version of Solus OS now and am running into slightly different problems I can open a new thread for but the tldr is that during the install the script hangs on loading game data after installing the wine mono and wine geko packages, since I already have wine, winetricks, and wine 32 bit libraries installed already. The version of wine in the Solus repos is 1.9.18, same version for the 32 bit libraries and and winetricks is 20151227 in case you need to know that as well. If there are other libraries this script relies on please let me know and I will be happy to open a ticket for Ikey and his team to get the libraries in the repo as soon as they can.


Apart from a few low-level libs (like libgcc or libGL), there should be no need for system dependencies. Lutris relies on its own versions of Wine, Winetricks and other various libs needed by games and emulators.

When you say it hangs while getting game data, do you get the LoL launcher? Or does Wine hang before launching anything?

Hangs before league launches or wine really after it installs the mono and geko libraries it just sits there saying loading game data and just hangs so nothing ever finishes.

This sound familiar for some reason.

Can you see if the current Git master branch has the same issue? (It’s just a matter of cloning the repo and running ./bin/lutris -dv)

Since we migrated to Python 3, you may have to install some additional packages.

Hi strider,

So just tried what you recommended and downloaded the master and ran the command and got the following error:

vash@vash-inspiron ~/Downloads/lutris-master $ ./bin/lutris dv
Traceback (most recent call last):
File “./bin/lutris”, line 46, in
from lutris.config import check_config # , register_handler
File “/home/vash/Downloads/lutris-master/lutris/config.py”, line 6, in
import yaml
ImportError: No module named ‘yaml’

Yeah, it’s Python3 now, you have to install the corresponding Python 3 dependencies.

Those are for Debian / Ubuntu:


That makes sense but do you happen to know what the python 3 dependecies are in the AUR or Manajaro (I switched back to see if I could get things working over there). Thanks in advance for your help.

The current dependencies for lutris-git should be good ( https://aur.archlinux.org/packages/lutris-git/ ). If not you can bug @Freso about it :smiley:

Fair enough I am currently taking a stab with Ubuntu Mate, since I had the most success with it prior and I have some other reasons. Currently the game has quit comes up when I try to launch League but that’s the farthest I have gotten and will install the above packages your provided me though I am trying 0.3.8 but will try out from Git as well. You’ve actually been really helpful and really appreciate it. You certainly have a user for life once I can get this rolling :+1::grinning:

Keep your progress updated here! I really hope you get this working because I’ve made a few changes in Lutris specifically to install LoL without any issue. I even demoed the installation at Riot Games and all went smoothly ^^

That is quite awesome that you demoed for Riot since i am sure they were thinking, well we don’t have to do that know :wink: .

So Manjaro was clearly a complete mess as far as getting this working, could be a library thing or could just be a Manjaro hates me thing right now. I bailed on both Solus, wouldn’t install very similarly to Manjaro, and have landed on Ubuntu Mate 16.04.1 LTS and initially 0.3.8 still didn’t work. I grabbed master from git and ran using the commands you provided and still no go. I then installed the rest of the python 3 libraries you mentioned, since 0.4.0 is no python 3, and finally blissful launching of lutris. Huzzah!

That said when running the League updater the update hung at exactly 32% and stayed their for an entire day, since I had it running to finish the install while I was gone, and didn’t continue until I closed the League updater and relaunched the game. I thought it hung when applying patches in the 40ish% so I closed the updater thinking it froze again and relaunched League and it did its old game has quit on me again.

I had to completely blow away League and its game data to re run the install to get it to work and as I type this I am sitting at 52% but applying the updates is painfully slow. Is there anything that could be done to optimize how fast it applies in the future or is that just how awesome League happens to be?

Also do you have a running tab or distros you know lutris works well on out of the box and or the distro your running while creating the magic?

As always thanks in advance and hopefully all that data helps you in some constructive way. :slight_smile: