Unable to install EA app on Ubuntu 22.04

I can’t install EA App.
EA App installer does not open during installation and EA App install folder is not created.
There are two videos to explain the problem a little more.
I don’t have a log file for EA App and the “lutris --submit-issue” command doesn’t work because I’m using flatpak.

Installation log: Ubuntu Pastebin
System information: Ubuntu Pastebin

I have the same problem for Ubisoft Connect and Battle.net.

1 Like

I fixed the problem.

I downloaded the latest installer from the EA site and ran it using Lutris’ “Run exe in Wine prefix” function (when having the EA app selected).

But I have another problem
When I launch EA App I get a black screen (even when restarting the app)

Using Lutris-ge-Proton7.43 (already tested with 8.1, 7.22, 7.1, it’s not working)

1 Like

Get off the Proton for that… the EA App doesn’t really work correctly. It’s fine for Steam, as it launches the game which connects up to the EA app services and tied to your Steam account, authorizes you.

However, if you need the EA App to be interactive, like you do when you want to use it to install EA games, try a Wine based runner. Do leave “D3D Extras” enabled, or it also will not display correctly.

I use my system wine (wine-tkg build) for the EA App and it, and the games I have work well, including Jedi Survivor.

You could try switching to lutris-7.2-2

Thank you for your answer.
I made the manipulations you told me, now EA App does not open (but it is running in Lutris)

Here is my configuration:

I just tried again with “wine-tkg” build and still got a blue screen.
The runner configuration is correct? I also tried with wine64.
Sorry for the “noob” questions and issues, I’m new to Ubuntu :smile:

Logs: Ubuntu Pastebin

EDIT: Always blue screen and crash report with “wine tgk 8.6.1”

That’s what I use for the EA App right now, my system wine. I use the wine-tkg-git build generator system (and build an Arch package using the sources). My current build shows as this in the Wine runner drop list in Lutris.

System (8.6.1.r3g4eb322dcc (TkG Staging Esync Fsync ))

But by selecting the custom wine executable, it should use that wine distribution. It may not run correctly for you (did you compile it, or is it a CI build from github or something?)

I use my own (current) builds of DXVK and vkd3d-proton, but they are versioned 2.1 and 2.8 respectively. I also disable the nvidia stuff (because I don’t have nvidia) and I disable the AMD FSR2. I don’t believe anybody should be trying to force-enable that. Sorry, I don’t see anything else in your configuration shown that could be wrong.

That EA App sure is a pain in the ass, and I’m lucky that I DO have a configuration where it works correctly. It does not, for me, in any other (for example if I try to use any of my Steam proton-tkg builds I get the black screen treatment. I got my EA games the Hell out of Steam (got an EA sub so I could just download anything) because the EA clients (Origin at the time) were always getting broken by Proton.

So the first time i tried this about two weeks or so ago i was getting the same results where it wouldn’t even install.
Tried a week later and it worked, but i remember there was an option between the base one and a beta client, but i don’t think i chose the beta one. Everything worked fine.

One failed harddrive and a complete OS reinstall later and i’m back here with it not working.

I’ve tried fiddling with it and the best difference i could really chalk this up to is proton8.1 wasn’t out yet, which my lutris seems dead set to use for setup. I change it to different runners, but no luck. The closest i get is with the lutris-GE-Proton-7-43, which i think i was running before. Anything else, even of what was mentioned above won’t launch; but if i use that one it does launch a little “connecting” window, before crashing in the backend on this

“wine: Call from 000000007B01263E to unimplemented function winegstreamer.dll.winegstreamer_create_video_decoder, aborting”

So thats the furthest i’ve gotten with this.

I’m using the exact same Wine version as you (wine-8.6.1-staging-esync-fsync)
I built it myself at first (but I couldn’t activate fsync, only esync is activated) but it doesn’t work (probably because Fsync is not included)

So I installed the pre-built (Wine Ubuntu CI · Frogging-Family/wine-tkg-git@f742de3 · GitHub), with fsync enabled, but it still doesn’t work

Yes, this EA App is really broken on linux.

Ok i think i got it to run; lutris-GE-Proton8-2-x86_64 just dropped so i tried that.
Now the problem is i had to run it twice. For some reason switching runners makes the program throw a bunch of errors basically complaining its for a 64-bit prefix and yours isn’t (despite it being so), but this only happens the first time so i shrug.

Now, the important part. I stopped the applicaiton, went into my processes and killed anything named wine. This is because despite ending it, the old wine seems to just hang out there. And with that i got a login menu and the game menu.

Now this did still require me to do the previously mentioned steps of when doing a fresh install, running the installer within the prefix because for some reason the lutris install just…doesn’t; based on the log i can’t really tell if it even attempts anything as it does a whole bunch of registry setup, but never mention of the actual installer. So downloading the EA App installer is a required step.

Well, that’s based on Proton 8.0-2 which Valve purportedly issued to fix this very thing (“again”), the EA App.

If Lutris doesn’t have that one in the list of wine runners, get it from Mr. GE here:

(Well, -3 released 23 minutes ago but -2 would still be available if for some reason you neeed to try it)

Wine-GE-Proton8-3 still does not fix the blue screen issue on EA (for me)
I would never make it :sweat_smile:

EDIT: Same issue with Wine-GE-Proton8-4 :sweat_smile:

I got it to work with Wine-GE-Proton8-4. I try to install via the Lutris installer and it ends up saying that it can’t find the eadesktop executable or whatever. I then downloaded the ea desktop installer app exe file from EA’s website and ran it in the wine prefix (run exe inside wine prefix).

The standard EA App install never worked for me, the Open beta install always worked for me but now that option is removed.

Recently when attempting to play Apex Legends it gets to a point where it keeps telling me there’s an update to install, attempts the update, finishes the update installation and then it tells me there’s an update to install.

After that I uninstalled Apex, redownloaded it as a whole and it still does the update loop.

After that happened I thought of uninstalling it from lutris and reinstalling it to see if it would work. Then I saw the open beta option was gone.

Everytime I install using the Standard install Lutris currently shows an error of: The executable at path /home/(MyUser)/Games/ea-app/drive_c/Program Files/Electronic Arts/EA Desktop/EA Desktop/EALauncher.exe can’t be found, please check the destination folder.
Some parts of the installation process may have not completed successfully.

The reason it can’t find it is because it never made those folders, when I look at that path there’s no Electronic Arts folder.