Ubisoft connect not working [solved]

AMD Ryzen 5 4650 APU, 32 GB Ram,
Opensuse Tumbleweed

Several weeks ago I had Lutris installed, then Ubisoft connect through installscript “latest”, finally Anno 1800 and 1404 by Ubisoft connect. Worked fine for about 2 weeks, then Ubisoft connect didn’t show up anymore.
Wanted to give it a try in a fresh installation, removed wine as well as Lutris completely and installed the latest versions from Tumbleweed-repository, and with Ubisoft connect running again installed Anno 1800 once more… Worked fine again for one evening, next day after restart, Ubisoft connect was hung at “checking for patches”, now it doesn’t even show up anymore.
Log from Lutris -d:
What I do not understand: everything was working fine, but without having touched the system, next day it doesn’t …
Anybody any idea? Thanks a lot in advance!

1 Like

Ubersoft turd updated and broke itself for you.

I’m not sure if it’s just broken (incomplete update) or you need to change your wine runner. There was indeed an update that broke itself for just about everyone (requiring a Proton workaround) but at the time it was reported to still work with Lutris-7.2-2 and the “D3D Extras” wine dll overrides.

If you want to keep trying with lutris-7.2-2, you could try reinstalling Ubisoft Connect through “Run EXE in Wine Prefix”

Barring that, see if the latest Proton based Lutris wine runner (GE-lutris-7-39 or something like that) solves this problem.

Thanks a lot, appreciate your advice very much!
After reinstalling through “Run exe in Wine prefix” the “wrong ELFclass”-messages disappeared, but Ubisoft connect seems to crash:
Guess I’ll have to try following your second suggestion.

1 Like

run on terminal
echo net.ipv4.tcp_mtu_probing=1 | sudo tee /etc/sysctl.d/custom-mtu-probing.conf
its work !!!

Just to mention: using lutris-GE-Proton7.39 for me doesn’t fix it either.

it works “WINE 7.0.6 -PROTON…” installation … “ProtonUp-Qt-2.7.7-x86_64.AppImage”

Inspired by vasilis last contribution, where I don’t like the rather old wine-version used, I gave Grogan’s second suggestion one more try, and look, using lutris-GE-Proton7.39 as runner now works very fine for me.
Guess, in my first attempt with this I must have done something wrong, but don’t know, what :wink:
Thank you very much for helping!

1 Like

This is a summary for everyone who doesn’t want to read every comment:

If you’re having issues with Ubisoft Connect not showing up and causing issues with your games. From the discussion, there are a few suggestions that you can try to resolve this problem:

Reinstall Ubisoft Connect through "Run EXE in Wine Prefix" using the Lutris application. This might fix any issues with broken or incomplete updates.

Try using a different Wine runner in Lutris. The suggested runners to try are:
    lutris-7.2-2 with "D3D Extras" wine DLL overrides

As suggested by vasilis, you can try running the following command in the terminal:
    echo net.ipv4.tcp_mtu_probing=1 | sudo tee /etc/sysctl.d/custom-mtu-probing.conf
    This command adjusts the MTU probing setting, which might help with network-related issues.

Another user, vasilis, mentioned that using WINE 7.0.6 -PROTON with ProtonUp-Qt-2.7.7-x86_64.AppImage works for them. You can give this a try if other suggestions don't work.

Remember to restart Lutris after making any changes to the Wine runner or other settings.

Good luck, and I hope one of these solutions works for you!