Trying to link Lutris to my Steam account : "Internal Server Error"


first of all I’m completely new here and I had never heard about Lutris a few days ago so maybe it’s as simple problem, but it has been 3 days since I first tried to link my steam account to Lutris and every time it seem to hang at “waiting for” after entering my credentials on the Steam website and then ~30sec later I get this :

Internal server error

Hu ho, something went wrong and it’s totally our fault.
We’ve been notified of this issue and we will fix it ASAP.

Even if it says the opposite I’m starting to think it’s a problem on my end as I see nobody complain about that here, I’m using Linux Mint Cinnamon 18.3 64 bits and Chromium

I hope someone can help me, thank you


I have the exact same issue, I’m new to Lutris too, only signed up yesterday, but I’ve tried linking my Steam account 3 or 4 times now, resulting in the same error message.

I’m running Ubunutu 17.10, x64 and using Firefox.

Steam just changed the privacy setttings options a few days(weeks?) ago, could be related to those?

I thought it might be related, but I checked the following for my steam profile:

“My profile”: Public
“Game details”: Friends Only (Tried setting this to Public too, no go"
“Inventory”: Public

Not sure what else is meant to be set to “Public” for this to work.

Just tried connecting my steam account and received the same error. It appears that there may be an issue with Lutris Steam API.
I know that the Lutris Dev was on holiday and was due back sometime yesterday or today, perhaps when he gets settled he can maybe take a look at it.