Trying to install LoL

I’m trying to install LoL but it gets stuck installing visual c++ 2005, any one with the same problem?
thanks in advance.

Using the installer on the website does the same thing for me. I am also having a really hard time trying to manually install it through lutris. I may just be more use to the playonlinux interface, but I have not been able to get LoL to install at all on lutris. I have also had a really hard time getting it to work on playonlinux as of late. If someone could update the runner to make the Alpha Client work that would be much appreciated otherwise I am just sticking to POL for league.

I’ve received several complaints about installers getting stuck during winetricks installs.
The problem is that I’ve never had such a problem myself, otherwise I would have fixed it already.

The only solution I see is for someone to “git gud” and find out the cause of the issue because so far no one has given be enough info for me to be able to fix the issue.
What I can do is try to gather relevant info in the info that would help with the said “gitting gud”. I’ll update this post with a link to the Wiki page when it’s done.

Ok the errors I get when I run the install script are:
ERROR 2016-12-09 12:07:19,297 [wine]:No system.reg found after prefix creation. Prefix might not be valid
ERROR 2016-12-09 12:07:20,836 [system]:Could not run command [’/sbin/fuser’, ‘/home/cblade/.local/share/lutris/runners/wine/staging-1.9.21-i386/bin/wine’]: [Errno 2] No such file or directory: ‘/sbin/fuser’
AttributeError: ‘NoneType’ object has no attribute ‘split’
Fontconfig error: Cannot load default config file
fixme:advapi:DecryptFileA (“C:\users\cblade\Temp\IXP000.TMP\”, 00000000): stub
Fontconfig error: Cannot load default config file
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
Fontconfig error: Cannot load default config file

I am running lutris 0.4.1 on Solus 1.2.1 because that is what is in the software center so maybe that is the problem?
I will try installing the newest lutris from source later today and running it again.

Ok so upgrading to Lutris 0.4.3 did fix the problem :grinning: guess that should have been the first thing to try

Is there anyway to upgrade the new client without it breaking?

Oh, wow, you weren’t running the latest client? That reminds me that I have to include the Lutris version in the support request feature we’re implementing.

Old versions of Lutris aren’t supported at all, for obvious reasons: they have known bugs that have been fixed in more recent releases.

Have you tried installing the new league client yet?

I just have and the new client doesn’t work (I guess a black rectangle).

I’m trying to edit Riot Games\League of Legends\RADS\System\user.cfg and set leagueClientOptIn = no but this doesn’t change anything.

Just got around to actually trying to play the game and now I am having problems connecting to the server.
Getting the error the login server did not respond. I wish RIOT would support us, if only a little bit :cry:

EDIT: reverted to wine version 1.9.2-staging-lol and it works so far

If you have issues connecting to the server, try downloading Wine 2.0-rc1 from Lutris. It’s compiled on Ubuntu 16.04 as opposed to 14.04 and solves connectivity issues (like the ones I had with Uplay or World of Warcraft)

Upgrading to 2.0 was the first thing I tried and it just gives me bugsplats on Solus 1.2.1.
I spent all yesterday trying to get the New client working in POL and then I spent today with lutris.
It is kinda sad though that I like messing with things trying to get them to work more than actually playing the game in the end.:joy: