Trouble installing Unreal Tournament 99 (SOLVED)

Hoping someone may be able to help me out.
I am trying to install UT99 via Lutris on my Raspbian 10 build using the “CD edition on Linux” installer.

I have tried using my original game disc, The files copied to a USB drive and the files copied to the devices HDD but whatever I do the installer will not find “unrealtournament.exe”

I am at a bit of a loss as to what to do, Any help appreciated.

I tried to upload the lutris-issue-report.json file but it tells me its not supported?

As a update I downloaded a ISO from a certain Archiveing website and that seems to detect the file ok, But I now have another issue.

Any help appreciated :slight_smile:

The installer is set for a 64 bit architecture. Are you running 64 bit raspbian?
If you’re running 64 bit, then delete the directory and reinstall as something has set it to 32 bit (previous install?)
The installer is written to download the 64 bit versions for wine and linux, and does not install the ARM version.

Seems the only available ARM patch from the OldUnreal git repo is 64 bit…so you could try downloading/tweaking that script to install that (lutris -i mycustominstall.json) - if running 64 bit raspbian.

If not…It might run on 32 bit, but you’d have to download and edit the install script, change the ARCH statements, and the download/install of the 32 bit versions, or for ARM native, compile the patch from source to feed into the install process.

Solved this (in a fashion) I managed to find a linux patch for the original game files on oldunreal.
Patched the files and now its running great presumably through Wine?
Either way sorted thanks :slight_smile: