Trouble getting any game working through Lutris

System specs:
Ubuntu 18.04 64bit
Ryzen 2700X
GTX 1070 with Nvidia 396.45 drivers
Lutris 0.4.18 installed via Ubuntu repo instructions
Wine 3.13 and associated dependencies installed via winehq staging repo

So the two games I’ve tried to get working are Steam versions of Witcher 3 and Brothers - A Tale of Two Sons.

To install Witcher 3 I open Lutris and I go here: and I click Install for STEAM(Windows) version. It opens up steam windows via wine and I login and it installs Witcher 3. Lutris tells me Witcher 3 is installed so I click run and I see Steam try to install some packages and they disappear and nothing happens. I open the Steam Wine Library and it says Witcher 3 is running but it is really not running.

To install Brothers - A Tale of Two Sons I open Lutris and I go here: and I click Install. It opens up steam windows via wine and it installs the game. Then Lutris has this little terminal of commands it is running to install supporting packages for the game but it never finishes. I actually somehow got this game working once but I deleted my entire lutris config folders in an attempt to install Witcher 3 (which removed the installed games) then I could never get it working again. I just tried to install Brothers again and it keeps saying things like “0150:err:ntdll:RtlpWaitForCriticalSection section 0x7bd1b6c0 “/home/ubuntu/buildbot/runners/wine/wine-src/dlls/ntdll/virtual.c: csVirtual” wait timed out in thread 0150, blocked by 017a, retrying (60 sec)”. Sometimes when I try to install it, the installer gets stuck here:

Executing w_do_call winxp
Executing load_winxp
Setting Windows version to winxp
Executing /home/username/.local/share/lutris/runners/wine/staging-3.12-x86_64/bin/wine regedit /S C:\windows\Temp_winxp\set-winver.reg

Is there something obvious that I am missing? Thanks!

check your process tree, is witcher3 exe running? if so then I’d say your window manager is screwing you which is common issue with wine gaming.

Yes I do see witcher3.exe in the background:
2947 1 30 01:13 tty2 00:00:08 C:\Program Files (x86)\Steam\steamapps\common\The Witcher 3\bin\x64\witcher3.exe

Any idea what the problem with the window manager could be? Since I’m using Ubuntu 18.04 with the out of box gnome I figure this would come up a lot more.

I also notice each time I run witcher 3 it runs through the first time setup steps before it launches witcher3 exe, is that expected behavior?

Ok so I was able to get Witcher 3 working! I changed the default installer wine 3.11 to the systemwide wine 3.13 I have installed. I also changed the default 0.61 dxvk to 0.63 (which I assume automatically downloaded that version which is the latest that is currently out). I’m getting a little under 60FPS at 1440P high settings.

Any tip for the Brothers game? I’ll try to change the versions on that game as well and see what happens. Thanks!

Ok so I got Brothers working by manually installing it. I basically followed the install script:

I installed dotnet40 using winetricks. For some reason when I try to install using the above script my computer just completely fails and gives tons of errors about things being blocked and things hanging. I pasted some of that in my initial post. Anyone ever run into a problem like that where the install script fails to install a Windows component but you can do it manually? Anything I can do to fix that?

Having wineSteam and winetricks is very tricky.

From my experience, Lutris is not a good front-end for wineSteam because it tries to bottle all your wineSteam games into a single Windows environment. The script you show there apparently makes a new wineprefix inside wineSteam’s wineprefix (it’s usually just $GAMEDIR, this one goes $GAMEDIR/prefix).

So what you’re probably doing manually is installing wineSteam on a wineprefix and applying winetricks to that prefix. What the script may be trying to do is installing some winetricks into a wineprefix inside another (not 100% on this).

I tried copying a wineprefix folder before and I got a permission error, probably because of having “z:” as one of the folder names (that Wine seems to use as a shell for Windows’ stuff). Maybe that’s what you experienced. winetricks tried accessing winestea/etc/etc/c:/etc/etc/etc/$GAMEDIR/prefix and failed on “c:”

Ironically, when you try to install any other DRM layer like BlizzardApp or Origin, Lutris scripts fully download and install such programs and THEN install the program there. This means each wineprefix has its own Blizzard/Origin (or Steam, if we extend).

In my opinion, this is a better way to manage weird conflicting game dependencies than having, say, wineBlizzard or wineOrigin runners.

The obvious downside is getting 500MB or so wasted every time for each game you want to install.