Back to the main site

Trackmania Sunrise eXtreme community-installer always hanging with "Source does not exist"-error at the end of the installation

Hello everyone,

when I’m trying to install Trackmania Sunrise eXtreme with the lutris[dot]net-community-installer you can find when you search for the game on lutris[dot]net I always get a “Source not found”-error at I think the final step of the installation-process (the step where it is supposed to extract the attached zip-file) leading to the installer hanging and needing to be cancelled.

You can find my lutris.log file here and my submit-issue-file here.

First a correction: the error is actually called “Source does not exist”.

Second: after looking closer at the lutris.log-file I found two additional errors:

010c:err:process:exec_process L"F:\\[my username]\\.cache\\lutris\\installer\\trackmania-sunrise-extreme\\extreme\\extreme.exe" not supported on this system
...
0114:err:process:exec_process L"F:\\[my username]\\.cache\\lutris\\installer\\trackmania-sunrise-extreme\\update\\update.exe" not supported on this system

Could the problem also be related to these two errors?

Ok, I managed to get the game running by manually installing it by first installing the game from the iso then installing the extreme-patch, then the 1.5-to-1.5.1-patch and then manually extracting the zip-file, renaming the extracted “TMSUNRISE.EXE” to “TmSunrise.exe” and then replacing the data in the game-directory with the data found in the zip-file as root-user.

I now think there might be two problems with the community-installer. 1st: it seemingly only installs the game itself and doesn’t install the two patches and 2nd: it seemingly can’t replace the data in the game-directory with the data from the zip-file.

Also if you are getting low graphics quality no matter how high you set the graphics settings then you need to increase videomemorysize by using:

WINEPREFIX=/path/to/your/TrackmaniaSunrise/pfx winetricks videomemorysize=2048

Or a lower or higher setting depending on your graphics-card.

I’m thinking about marking this thread “solved” though considering I actually didn’t solve the problems with the community-installer itself and instead installed Trackmania Sunrise eXtreme manually I’m not sure if this issue can be considered “solved”.

Irrelevant, but do you think we’ll be able to get this working on the Steam Deck with it’s custom version of SteamOS?