Back to the main site

Tomb Raider 1

Pour une raison que j’ignore Tomb Raider 1 ne fonctionne plus. J’ai utiliser la version gog Ati, puis la version CD Ati.

hibon@hibon-System-Product-Name:~$ lutris
2020-12-19 10:29:46,605: Lutris 0.5.8
2020-12-19 10:29:46,605: Using NVIDIA drivers 455.38 for x86_64
2020-12-19 10:29:46,605: GPU: GeForce GTX 1660
2020-12-19 10:29:46,605: GPU: 10DE:2184 1458:3FC8 (nvidia drivers)
Exception ignored in: <function InputDevice.del at 0x7fa2e1eee3a0>
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/evdev/device.py”, line 159, in del
self.close()
File “/usr/lib/python3/dist-packages/evdev/device.py”, line 304, in close
super().close()
File “/usr/lib/python3/dist-packages/evdev/eventio_async.py”, line 54, in close
loop = asyncio.get_event_loop()
File “/usr/lib/python3.8/asyncio/events.py”, line 639, in get_event_loop
raise RuntimeError(‘There is no current event loop in thread %r.’
RuntimeError: There is no current event loop in thread ‘Thread-3’.
Running gamemoderun /home/hibon/.local/share/lutris/runners/wine/lutris-6.0-rc1-x86_64/bin/wine /home/hibon/Games/tomb-raider-i CD/drive_c/windows/syswow64/wineconsole.exe c:\TOMBATI\TOMBATI.BAT
Initial process has started with pid 54419
Start monitoring process.
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
wineserver: using server-side synchronization.
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Monitored process exited.
Initial process has exited (return code: 0)
All monitored processes have exited.
Exit with returncode 0
2020-12-19 10:30:00,649: Game still running (state: running)
2020-12-19 10:30:00,649: Stopping Tomb Raider I - CD - TombATI HD (wine)
2020-12-19 10:30:44,853: Shutting down Lutris
hibon@hibon-System-Product-Name:~$

Ps: je viens d’essayer avec gog connecté et le chargement du jeux par gog, même combat ???

Autre log

Running gamemoderun /home/hibon/.local/share/lutris/runners/wine/lutris-6.0-rc1-x86_64/bin/wine /home/hibon/Games/tomb-raider-i GoG/drive_c/windows/syswow64/wineconsole.exe c:\TOMBATI\TOMBATI.BAT
Initial process has started with pid 58134
Start monitoring process.
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
wineserver: using server-side synchronization.
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Monitored process exited.
Initial process has exited (return code: 0)
All monitored processes have exited.
Exit with returncode 0

salut Berbon, essaie ces manips:
une fois installé, change la version de wine à une version inférieure à 6.
Puis lance winetricks et install vcrun 2015.
Relance le jeu, cela fonctionne?

Merci de tes explications claire et limpide, effectivement maintenant ça remarche.
Que c’est il passé avec les différents installeurs.
Par contre Openlara fonctionne bien mais je crois qu’il n’y a pas le deuxième épisode ???

Nous avons un bug qui empêche winetricks de fonctionner avec wine 0.6. Les scripts eux sont corrects et fonctionneront de nouveau lorsque le bug de winetricks sera corrigé.

Je ne crois pas qu’OpenLara soit prêt pour le 2éme épisode.

Bonjour, je viens de voir que tu as fait un nouveau installeur, le petit soucis c’est que le fichier tr1.bat ne s’installe pas dans C (C:\tr1.bat) et après l’avoir installé manuellement, le jeux ne veut pas démarré.

Donc je reste avec la solution préconisé au dessus et ça marche.

PS: Personnellement je préfère les graphismes de JC donc je les installe après coup.

Ooops, un oubli, c’est corrigé, merci de me l’avoir signalé.
De quels graphismes parles-tu?

Je voulais dire texture de John Capone (JC_TombAti_v1.2.exe)

Je viens de réinstaller Tomb Raider , le fichier BAT est bien installé maintenant mais arrivé a l’écran de titre aucun choix n’est possible sauf le EXIT

avec lequel des 3 scripts? CD? GOG?

Les deux mon capitaine

Je viens même de l’installer par steam, même combat

Berbon je viens de tester, c’est toujours le même problème, tant que la version de Wine utilisée par défaut est la 6rc1, ces scripts ne fonctionneront pas.

Ok

Si tu as envie de tester, je viens de publier deux nouveaux scripts:
Tomb Raider 2 + OpenLara
Tomb Raider 3 + OpenLara

Fantastique, les deux fonctionnent, a part les touche 5 et 9 qui ne fonctionne pas mais je suppose qu’il doit y avoir des point de passage avec sauvegarde automatique.
Encore bravo

Ps: aurais tu désactiver les touches 5 et 9 car dans la Tomb Raider 1 OpenLara il ne fonctionne plus.

cela doit être un paramètre interne à OpenLara? Un bug ou autre…je vais me renseigner.

je viens d’en discuter avec le développeur, il y a en effet un bug, OpenLara utilise un clavier qwerty et ne s’adapte pas à celui de l’utilisateur. Il sera prochainement corrigé. En attendant tu peux utiliser l’option “us keyboard” disponible dans les options de Lutris.

Excuse mon ignorance mais comment je fait depuis Lutris pour utiliser l’outil «us keyboard» ???

Ps: excuse moi de faire mon chiant mais il ne manque plus que le deuxième épisode du 1 pour que ça soit complet.

Suite à ton signalement j’ai prévenu le dev et il a déjà corrigé le bug. Du coups j’ai mis à jour le binaire et tout ça un dimanche!!! :sweat_smile:
Tu n’as plus qu’à réinstaller le jeu pour que cela fonctionne.
Les autres épisodes sont prévus, mais je ne peux te dire quand.

C’est toi le meilleur.

Ps: T1 T2 T3 tous fonctionne (5 et 9 sont opérationnelle)

Comment dire, il y a quand même pas mal de bugs.
Le T1 a part des bugs de prise de trousses de soins il compte les secrets.
Le T2 pour l’instant je ne suis pas aller très loin et pour l’instant pas de bugs
Le T3 quasiment injouable, ou je marche en dessous le décor ou je nage en hauteur.

Mais bon c’est une expérience intéressante.