The winesteam runner shuts off prematurely

trying to install wine-steam games is a nightmare cause the thing shuts off after mere seconds of download and has to be babysat and constantly restarted, this has always been and is it too much to ask to fix this behavior?

I’m not sure you’re doing it the right way, this should never happen.

I have the same problem.If I start a game right away I can keep playing it.Last night I tried prey (2006).But when I try to use steam client it crashes and takes down the virtual desktop with it if I use the menus in steam.If I let it download the games it crashes in every 5-10 minutes.I use arch with 4.10.13-ck kernel with nvidia 378.13 drivers

I’ve had several reports about this, I’ll try to reproduce it and push a fix in 0.4.10.

I’m trying to reproduce this bug and I’m reviewing the related code and indeed, there is no way the process monitor could shut down steam during an installation.

The only way this could happen is if the game was manually added using its Steam appid then the game was launched as if it was installed. This scenario would indeed trigger the process monitor timeout.

I cancelled the installation I was doing after seeing everything was doing fine then tried to finish it by manually adding the game with its appid. This did indeed stop the install after 5 minutes, as I would have expected.

This is a very awkward way of installing Steam games but it could cause legitimate issues when a game receives a big update. We have everything needed to fix this right in Lutris, this will be patched in next release.

I know, a whole year passed since last reply in this tread, but I encounter the same problem multiple times. For example now I try to install Warhammer: Vermintide II with DXVK in new clean wine bottle. I create new bottle in Games folder, add a game, select Steam installer and install the damn thing. Next I add DXVK 64 bit libs in system32 folder. I run Steam and begin download the game… and after exactly 5 minutes Steam closes. Here’s some logs:

[Snow_Guard@localhost ~]$ lutris
INFO 2018-04-27 10:12:30,402 [lutriswindow]:Connected to as Snow_Guard
wine: cannot find L"C:\windows\system32\winemenubuilder.exe"
WARNING 2018-04-27 10:18:21,438 [wine]:Some wine processes are still running: 16921

[Snow_Guard@localhost ~]$ uname -a
Linux localhost.localdomain 4.15.17-300.fc27.x86_64 #1 SMP Thu Apr 12 18:19:17 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux