The Sims 2: cannot locate CD-ROM

I downloaded The Sims 2 through, and installation seemed to work just fine. However, when I try to run the game, I get the error “Cannot locate the CD-ROM: Please insert the correct CD-ROM, select OK and restart application.” I still have the ISO file of the game mounted, which to my understanding should function as a CD-ROM. Is there something I can do to make Lutris recognize this CD-ROM? Cheers!

Edit: I installed the Universal DVD version, not the Origin version, as I assumed there’s no way to get the game for free if I installed the Origin version. Is that true?

Have you tried mounting the ISO as a UDF file? In Ubuntu support for UDF disks is appalling and you have to specify you are mounting a UDF disk.

Thank you for your reply! I mounted the ISO using sudo mount file.iso /media/iso -t udf -o loop and I verified that the image was indeed mounted as UDF type. However, The Sims 2 still complained that it could not find a CD-ROM :frowning:

Edit: I also tried sudo mount file.iso /media/iso -t iso9660, which did not work either