Back to the main site

Terrible framerate in Diablo III installed via battle.net

Hello all, I’m a recent refugee from PlayonLinux, and am already in love. However, whenever I install Diablo III using the battle.net installer, the game is so laggy that it is basically unplayable (think 2 frames per second).

I have an nvidia 1080 ti with 32gb of ram and an i7, so I’m certain the issue isn’t my rig itself… I’m guessing something is configured wrong but I have no idea where to start. I did install the recommended lib32 dependencies from the GitHub page.

Hi,

Yesterday I tried the dxvk version of the Blizzard App and testet D3. I had very good results, just a littlebit dark Charakter Models. But its still playable.

Are you trying to play 64bit client or 32? I’ve unplayable fps only if start D3 64bit client. You can switch it via Battle.net’s “game options”.

1 Like

Is this what youi’re referring to? I’m unable to launch it if I switch it to 32 bit.

I thinik he was referring to something that can be changed from inside the battlenet launcher itself.

You could try a different runner, see if that helps.

In main lutris window, right click “wine” in the left panel and then “Manage Versions”, tick ge3.6 and it will download. Now right click your battlenet banner and “configure”, go to third window “Runner Options”, select ge3.6 from the wine version pulldown. if you want to try DXVK it can be enabled and disabled there as well.

Save and now right click your battlenet banner again select “wine configuration”, this will rebuild the wine bottle to ge3.6
Now try running the game see if there is a difference.

Hmm… when I enable DXVK, it says a DLL is missing in will not launch. No dice with switching to ge3.6. It had no effect on the gameplay.

Switching the battle.net client to 32 bit resolves the issue. Here’s a screenshot of where I found it.

DX11 with D3 does not work with OpenGL backend (for more then 1 fps). Indeed use 32 bit (which forces dx9), it is said on the installer page to do this.

If you can get DXVK running (up to you), you can use DXVK with 0.53 and you can use DX11 with high framerates (and no lightning issues).

@Dox I have DXVK enabled but I don’t understand what you said, “DXVK with 0.53”. How do I select “0.53”?