Temple of Elemental Evil (GOG) doesn't respond

Hi ! This is going to be a two parter.

  1. After installing TOEE, I got the “File not found” error message that seem to plague GOG games.
    I checked the file path and noticed a repetition :

/home/goji/Games/temple-of-elemental-evil-the/drive_c/GOG Games/drive_c/GOG Games/Temple of Elemental Evil/ToEE.exe

  1. So, I just shortened the path by erasing the repetition, and now the game “seems” to start.
    But then the screen “freezes” with a “Wine - Temple of Elemental Evil has stopped responding” warning. If I click anywhere it “unfreezes” (going back to the desktop), and if I click on “Wait”, the warning just pop back in after a second, and the game never starts.

Sorry, I forget to put my log :

Running /home/goji/.local/share/lutris/runners/wine/lutris-5.5-2-x86_64/bin/wine /home/goji/Games/temple-of-elemental-evil-the/drive_c/GOG Games/Temple of Elemental Evil/ToEE.exe
Initial process has started with pid 33906
Game is considered started.
esync: up and running.
wine: Unhandled page fault on write access to 7C002FCC at address F76582EA (thread 0009), starting debugger…
Can’t attach process 0008: error 5
Initial process has exited.

ToEE from GOG has Platinum rating on WineHQ with Wine v1.7.18 and v3.2. Have you tried running it outside of Lutris (in the same wineprefix and with same Wine binaries, of course)? You can also try switching it for a version of Wine it’s been known to work with.

Thanks for the advice !
I’m a pretty much new on the whole Linux/Wine scene.
Could you give me more details pointers, or link me to a tutorial ?

First thing is: the path to the executable run by Wine, as well as location of the wineprefix can be found in game link config.

Then, in the “Runner options” tab, you’ll find the name of the Wine version to look for. Unless it says System (which means default wine available from command line), the Wine binary location will be ~/.local/share/lutris/runners/wine/{version}/bin/wine (there’s also “Custom” but I’m pretty sure it’s only ever selected manually).

The simplest way to run the executable (once) would be to run

WINEPREFIX="/path/to/wineprefix" wine /path/to/executable

with /path/to/wineprefix and /path/to/executable replaced with the path you found in the game config (and in case it’s not using system wine, wine would need to be replaced with path to Wine executable).

Alternatively, you can use Q4Wine for that purpose. First, register (Ctrl+M) the Wine version in the app (if it’s not the system Wine, which is called Default in the app):

Then, in the Prefixes tab, press “Create new”, and register the game prefix (“Prefix path” in the General tab, “Version” in the Wine Settings tab, and also “Architecture” in General if there’s a specific value in “Prefix architecture” in the game config). Skipping the Setup tab (as the prefix already exists), select the prefix in the Programs tab, and open New Icon dialog using popup menu (right-click) in the right panel. Then you can simply select the executable (“Program” field), and also an icon if you want it (button with the icon to the right of Icon Options); then just run the newly-created icon.
Logs for these runs can be found in the Logging tab (unless it’s disabled, you can check/toggle it there).

As for downloading a specific version of Wine, you can do it in the Wine version manager of Lutris (by clicking a box icon next to Wine runner). But, the oldest one there appears to be v4.0… Dunno, maybe a Slackware release will work? I’d try the oldest version from Lutris first.

Thank you for everything !
I’ll try that when I have some time.
I tried installing it, and playing it directly through Wine with default settings, no success.