Switching window focus results in being unable to regain game focus

I am running Genshin Impact via Lutris. The game runs fine, but when I alt-tab out to another window, the game window disappears despite the game still running. I can still hear the game sounds, but there is simply no window to switch back to for the game. This also happens if I switch to a different workspace, rather than alt-tab to another window.

I’ve noticed that even when I have focus on the game window, the alt-tab menu doesn’t show an icon for the game.

Fedora 34

I’ve tried runners lutris-7.1, lutris-fshack-7.1, lutris-fshack-6.21-6, lutris-fshack-6.14, lutris-6.10-3, and wine-6.8. All show the same behavior.

Other games launched via lutris do not have this behavior.

log paste

I’ve also tried using the virtual desktop - the game fails to launch entirely when using that option.

Logs when using virtual desktop are much shorter:

Started initial process 1908413 from /home/$user/.local/share/lutris/runners/wine/lutris-fshack-7.1-x86_64/bin/wine cmd /C launcher.bat
Start monitoring process.
esync: up and running.
002c:fixme:winediag:LdrInitializeThunk Lutris Wine 7.1 is a testing version containing experimental patches.
0024:err:module:LdrInitializeThunk “comctl32.dll” failed to initialize, aborting
0024:err:module:LdrInitializeThunk Initializing dlls for L"C:\windows\syswow64\start.exe" failed, status c0000005
Monitored process exited.
Initial process has exited (return code: 1280)
Exit with return code 1280