external windows don't open

Im having problems with survivio:
Using the runner of browser, the game doesn’t open, also if I close my browser the game doesn’t open too.

Using the runner of HTML5, the game opens but I can’t login into my account. In the log, appears a message that a external window has open, but I don’t see any window opening.

Here the .JSON: pastebin com zJV5dZQH

The log and the text that appears in the terminal is the same:
With HTML5
With browser

Looks like in the both cases Lutris tries to open a external browser window but It doesn’t appear.

Is there a reason to play this using Lutris instead of via a native web browser?

At least with the html5 one the error looks like it might be:
(--icon:4973): GLib-GIO-CRITICAL **: 16:30:15.496: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

I don’t really see anything with the browser log. It just says “Game is considered started.” and that’s all - there’s no error after it has starterd. Maybe “Gtk-Message: 16:31:47.052: GtkDialog mapped without a transient parent. This is discouraged.” But only maybe.

Hi! Thanks for replying.

The reason is that I use Firefox as browser, and here the performance is bad (Searching for this I didn’t find how solve it). But with other browsers, like Vivaldi, the game runs fine; I don’t like much to have a browser only for playing so I wanted to try Lutris. When I tried with the HTML5 runner, the performance was perfect, but with the problem that I can’t login…

I’ve noticed that I have an update for install, so I installed it and also switched to xfce desktop; both things worked, so the browser runner problem is solved.

In the case of the html5 runner, the window opens, but opens in Firefox and not in the HTML5 runner that runs the game, so when I get logged on Firefox, it redirects me to in Firefox, so I don’t get logged in.

Maybe the HTML5 runner is not made to play games with this type of login, but do you know any way to log with the runner?

I just don’t know enough for browser based games and Lutris. Maybe one of the Lutris devs can help further.

It really depends on what is being used. Wine would probably be a Wine problem. Native might be native so game dev or system problem maybe, browser I’m not even sure what that is with Lutris.