Suggestion for new Open Beta MTG Arena installer

If anyone is having problems trying to get Magic: The Gathering - Arena to install after the latest OpenBeta client update, I suggest installing manually for the time being. Apparently, updating Unity games is still not working 100% right on Wine.

To patch correctly, I had to restart MTGA.exe several times to get all files to download. During the last 3 files, I thought I had to put the game in single core mode, because all the errors had the name “thread” on them, making me believe some kind of multithreading problem was being randomly generated by the patcher.

The process is as follows:

  1. Create a new wineprefix

WINEPREFIX=/name/of/mtga/folder WINEARCH=win32 winecfg

  1. Install the required wineprefixes following the script

WINEPREFIX=/name/of/mtga/folder winetricks dotnet452
WINEPREFIX=/name/of/mtga/folder winetricks xact
WINEPREFIX=/name/of/mtga/folder winetricks corefonts
WINEPREFIX=/name/of/mtga/folder winetricks win10

  1. Download the open beta client and install it in the prefix

WINEPREFIX=/name/of/mtga/folder wine /path/to/installer/MTGAInstaller.exe

In this step, you can apparently put /quiet in the end of the command line to skip some unreadable installer bits. The same can be done for winetricks dotnet452, but I’m not sure if the proper way is winetricks -q dotnet452or winetricks dotnet452 /q or something. It shouldn’t make a difference whether you use a GUI or leave it to the quiet installer, but quiet mode requires less mouse button presses.

(EDIT: updated steps 4 to 6)
4. Update the game calling MTGA.exe. This step will fail several times, but the number of updates keeps reducing (from 1 of 60, to 1 of 20 and so on). Whenever it fails, start it up again.

env WINEPREFIX="/home/USERNAME/Games/MagicArena" wine “/home/USERNAME/Games/MagicArena/drive_c/Program Files/Wizards of the Coast/MTGA/MTGA.exe”

  1. By the end of the updates (about 1 out of 5) I simply couldn’t keep using this method. I used this command to start the game using single core mode and it could finish updating the remaining packages.

taskset --cpu-list 1 env WINEPREFIX="/home/USERNAME/Games/MagicArena" wine “/home/USERNAME/Games/MagicArena/drive_c/Program Files/Wizards of the Coast/MTGA/MTGA.exe”

  1. When everything is updated, you’re safe to go back to multicore mode. Create a launcher for the actual game so you don’t have to use the command line all the time

For example, you can create a launcher in the desktop generally right-clicking the desktop and pressing “create new launcher”. This varies with Desktop Environments and distributions. The launcher command should be similar to

env WINEPREFIX="/home/USERNAME/Games/MagicArena" wine “/home/USERNAME/Games/MagicArena/drive_c/Program Files/Wizards of the Coast/MTGA/MTGA.exe”


Ran it until step 4. I get the following spammed in my console:

00c8:fixme:dxgi:dxgi_swapchain_Present Unimplemented sync interval 1

While MTGA is “Checking for updates”, but for ages, just the three dots blinking.

What should I try?

Edit: After 30-40 minutes I stopped the launcher and my console said:

00c8:fixme:dxgi:dxgi_swapchain_Present Unimplemented sync interval 1
0362:fixme:win:UnregisterDeviceNotification (handle=0xcafeaffe), STUB!
0362:err:d3d:context_set_gl_context Failed to set pixel format 1 on device context 0x18004a.
0362:fixme:d3d11:d3d11_immediate_context_Flush iface 0x2797d14 stub!
0362:fixme:d3d11:d3d11_immediate_context_Flush iface 0x2797d14 stub!
0362:fixme:ntdll:EtwEventUnregister (deadbeef) stub.
0362:fixme:ntdll:EtwEventUnregister (0) stub.
0217:fixme:file:CancelSynchronousIo (0x54): stub
0217:fixme:ver:GetCurrentPackageId (0x33fe24 (nil)): stub
016f:fixme:ver:GetCurrentPackageId (0x33fe24 (nil)): stub

"fixme"s are usually ignorable in these types of applications. Have you tried running the game without the single core command? Just take away the taskset --cpu-list 1 part.

The only reason I proposed to run in single core mode it because I kept getting some “GC Thread” error things I can’t remember exactly.

What should happen is that your game should start updating, but it will not be able to finish. If it is, then report back because the way your system/processor operates may be different and not require step 4, being able to go straight to 5.

EDIT: p.s.: please try to at least have the update to start. It should give the “1 of 60” or whatever screen, and that’s a good point to be. If it doesn’t reach that place in about 5 minutes, I suggest closing and running the command again.

1 Like

Yeah, it worked! :slight_smile:

I know this with the updates, I played the game for almost two months on Linux before. Didn’t try your tip for the launcher yet, but I’ll keep you updated.


Edit: Okay, I started it again and again. It went from like 1/44 to 4/4 files downloading, but then it started over again with “Downloading 1 of 2 files”, so I did the same thing, but it crashes again and again with the same error “Fatal error in CC” like before, but there is no progress at all. :confused:


0069:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0069:fixme:ver:GetCurrentPackageId (0x33fe24 (nil)): stub

Edit3: So it works now, I’ve run it again with the single core command above. Thanks!

That’s great! It’s fine when the number of files keeps going down, because the patcher is, fortunately, smart and doesn’t redownload (it seems that it can’t pick up downloads in the middle, though).

So, please confirm a few things:

  1. What’s your processor? Intel? AMD?
  2. Did you update in multicore mode and change to single core mode only by the end?

Great to hear it worked!

  1. I’m running an Intel i5-3320M
  2. I’ve first run it without the single core command. Then the game started a second update interval. After 20 times a changed to the single core command. Then it worked.

btw: The launcher works fine, thanks!

1 Like

Glad to know everything is working! I updated the instructions to suggest using “multicore”(regular) mode in the beginning and then switch to single core mode for the last remaining packages.

The game itself runs fine with multicore mode.

Good to know the script is working again (updated 21h ago since this post) ^^ I had no idea how to edit it properly and script creation was restricted.

1 Like

The game sometimes needs to be forced to shut down. It doesn’t run that smooth, but I guess, this is the price for playing on Linux :wink:

Great that the script was finally updated!

OH I didn’t add this bit of information lol!

Don’t use Antialising, it will make your screen black. Try to play on lower settings BECAUSE it will “leak memory” (apparently) and start become slower and slower the more matches you play. Every 3 matches or so I close the game to reopen it up (about 1 to 3h of gameplay) so I don’t get this staggering

Something which really bothers me are the updates. Is there a better way, than to reinstall the complete game?

The server Status is still on maintenance, so I can’t confirm anything at this point (maybe that’s what you got?)

Maybe we will be able to keep updating using MTGA.exe as long as they keep the Open Beta Status (I was able to play the whole Closed Beta with the same method, only needing to change in this new phase, new client).

We’ll see if any issue comes up and report any findings here.

I just deleted files in WOTC/MTGA/MTGA_Data/Downloads called downloads.manifest and Manifest_ccabe… big hash and the game started downloading files again. After that, he got into the same 845 version, instead of the required 850 (or is it 852?).

Anyways, it SEEMS possible to update the game without reinstalling, but I couldn’t track the exact file to trigger it. For now, since clients may change from week to week, it’s simpler to just re-download the whole thing and spend some time re-updating.

Temporary solution:

I downloaded MTGAInstaller.exe again from the official website and installed it over my full directory

WINEPREFIX=/path/to/MagicArenaPrefix wine /path/to/MTGAInstaller.exe

(you can probably use something like /q for quiet installation mode, but the process is quick as it is).

I then used my existing launcher for MTGA.exe. It said right from the start (number may vary slightly) and then proceeded to download 1 of 16 parts. Same problem, as before, but I had to restart only 1 time to fully update the game. No “single core mode” needed.

EDIT: game is not working atm. I’ll reinstall and “back to the draftboard” I guess… I feel like this is a problem with Unity games…
EDIT 2: my previous build had the game running, but whenever I pressed “play” it would get stuck on the main menu. I reinstalled everything with the given Lutris script and, after the tedious update process, it works again.

There has to be a better solution :expressionless:

There’s a new patch today (which means I’m installing the game again) and one part reads


  • Resolved a caching issues that prevented some players from automatically updating to the latest version of Magic: The Gathering Arena .

Maybe this means we will have less problems updating in the future as well… let’s hope.

Doesn’t work for me for weeks.

I used the script, I tried the suggestion here again. But the game just freezes while “Checking for updates”.

There’s supposedly a specific fix for that kind of problem I don’t know much about. Since I’ve been removing and reinstalling MTGA every update they release (ugh), I can attest the script is working well on my Linux Mint machine.

I recommend using a vanilla version of Wine-Staging to run MTGA, since it doesn’t seem to benefit from ESYNC or DXVK and I had those things cause problems.

Other than that, if you want to debug, start lutris with lutris -d and see if there’s some loop or error message (that’s not related to winemenubuilder).

As of Dec 14 update installer is broken. took 5 trys to get it installed but games crashes right away. game was working fine untill dec 14 update

Good Day Guys,

I have the run the script from the games page, and it seems to install, but its missing some fonts, I can navaigate through the first page, but when it asks me to login it will not take anything…

I have installed all the apps in winetricks

I am using a fresh install of linux mint 19.
Intel Core I7 Processor
Nvidia 390 Drivers
16GB Ram


I resolved the issue…

I uninstalled all WINE Packages via the Software Manager

Re-installed WINE-Staging
Re-installed Arena

and Voilà it works…