Struggling with configuring runners

So I downloaded battlenet and starcraft on lutris and post install the game launched itself. everything was good but when I exited and tried to launch the game myself I couldn’t find anything in lutris, so I’ve tried to configure a wine runner directed at the starcraft executable. I can’t get it to do anything in lutris, it just seems like it’s not launching at all.

So when I manually went in to the starcraft directory and opened up a terminal and and run “wine Starcraft.exe” I can see battlenet starting to open up, but wine falls over (see screenshot)

Here’s a pastebin from a lutris dump if it helps. I can only assume I’ve just badly configured the runner in lutris because I know the game runs on my system

Are there any further details I can provide that might be useful?
Thank you


  1. are you on lutris 0.5.16 → check in about lutris
  2. did you click the + button on the lutris titlebar → search for game → and use this installer to install
  3. did you install to the default folder (/home/username/Games/battlenet) or did you install somewhere else?

Thank you for your response.
Lutris version is:

Clicked the install button in the bottom right.
It launched after install and I could play the game. Now when I try to launch it or launch it through Lutris it won’t start.

Yes it is in that directory

/home/USER/Games/battlenet/drive_c/Program Files (x86)/ Launcher.exe

old lutris version - use the links from this website → downloads and get the 0.5.16 deb

in terminal, go to the folder where the downloaded file is and run:
sudo apt install ./lutris (and press the tab key to complete the file name)
it will complain at the end, but if you have closed lutris before doing this, the install should be successful. Run lutris -d in terminal and it should eventually say the new version is 0.5.16
Once this is done, in lutris → three lines on the title bar → preferences → global options → enable Advanced at the top and then change the vulkan ICD loader field to NOT say unspecified.
Restart lutris and install per normal - (delete the existing battlenet folders - prefix is no good)

ok I’ve done all that and it looks good until I try to launch it. at which point I get a ‘wine debugger’ window that opens and closes about 5 times and it looks like something called conhost.exe is falling over.

strangely the battlenet appication doesn’t close, but it just sits there so I guess it’s hung up

wine version HAS to be wine ge 8-26

On the left hand pane, under runners, click wine then the folder and make sure that this is installed.
Then right click the game in lutris → configure → runner options tab and set the wine version to wine-ge-8-26

Is this a common problem or are you some kind of wizard?

Everything is 100% now

Late last year changed a core component which someone at codeweavers worked out could be tentatively solved using an environment variable WINE_SIMULATE_WRITECOPY=1 - instead of having everyone put this in or update the installers, it was easier to incorporate the fix into the wine-ge-8-26 which is now also the default wine version for lutris.

bad blizzard, no donut
thanks a bunch buddy