Back to the main site

Strange Mouse Problem


#1

So I have recently swapped from Windows 10 to Linux Mint. So far I am loving everything about Mint/Linux. I have 1 problem I cannot figure out how to fix with World of Warcraft. I start the launcher just fine with no problems. Launch WoW fine, I can still see the mouse at this point. Go past the load screen to the Character select screen, can still see the mouse. In game is where the problem starts. So this is where it is strange. I can see the mouse over addons and spells/windows(spell book, friends list, game menu), but when as soon as i move the mouse over the environment or want to click a player on screen the mouse disappears. I feel like this some sort of layering issue, since addons are on top of the game and windows of the game would be like the second layer, I feel like the mouse is being pushed to last layer whenever not on one of those examples. I’m going to put a copy of my Config file here.

SET portal β€œUS”
SET textLocale β€œenUS”
SET audioLocale β€œenUS”
SET agentUID β€œwow_enus”
SET hwDetect β€œ0”
SET videoOptionsVersion β€œ15”
SET gxApi β€œD3D9”
SET gxWindow β€œ1”
SET gxMaximize β€œ1”
SET graphicsQuality β€œ3”
SET RAIDgraphicsQuality β€œ7”
SET farclip β€œ3000.000000”
SET horizonStart β€œ800.000000”
SET particleDensity β€œ10.000000”
SET particleMTDensity β€œ20.000000”
SET waterDetail β€œ1.000000”
SET rippleDetail β€œ0.000000”
SET reflectionMode β€œ0.000000”
SET sunShafts β€œ0.000000”
SET refraction β€œ0.000000”
SET groundEffectDensity β€œ16.000000”
SET groundEffectDist β€œ70.000000”
SET projectedTextures β€œ0.000000”
SET shadowMode β€œ0.000000”
SET shadowTextureSize β€œ1024.000000”
SET shadowSoft β€œ0.000000”
SET SSAO β€œ0.000000”
SET DepthBasedOpacity β€œ0.000000”
SET textureFilteringMode β€œ2.000000”
SET terrainLodDist β€œ250.000000”
SET wmoLodDist β€œ300.000000”
SET terrainMipLevel β€œ1.000000”
SET worldBaseMip β€œ1.000000”
SET OutlineEngineMode β€œ0.000000”
SET lightMode β€œ0.000000”
SET lodObjectCullSize β€œ27.000000”
SET lodObjectCullDist β€œ30.000000”
SET lodObjectMinSize β€œ80.000000”
SET lodObjectFadeScale β€œ80.000000”
SET RAIDfarclip β€œ7000.000000”
SET RAIDDepthBasedOpacity β€œ1.000000”
SET RAIDgroundEffectDensity β€œ80.000000”
SET RAIDgroundEffectDist β€œ200.000000”
SET RAIDterrainLodDist β€œ500.000000”
SET RAIDwmoLodDist β€œ400.000000”
SET RAIDterrainMipLevel β€œ0.000000”
SET RAIDworldBaseMip β€œ0.000000”
SET RAIDtextureFilteringMode β€œ5.000000”
SET RAIDprojectedTextures β€œ1.000000”
SET RAIDshadowTextureSize β€œ2048.000000”
SET RAIDshadowSoft β€œ0.000000”
SET RAIDreflectionMode β€œ0.000000”
SET RAIDrippleDetail β€œ1.000000”
SET RAIDparticleDensity β€œ80.000000”
SET RAIDparticleMTDensity β€œ100.000000”
SET RAIDLightMode β€œ2.000000”
SET RAIDlodObjectCullSize β€œ18.000000”
SET RAIDlodObjectCullDist β€œ30.000000”
SET RAIDlodObjectMinSize β€œ54.000000”
SET RAIDlodObjectFadeScale β€œ100.000000”
SET componentTextureLevel β€œ1.000000”
SET RAIDcomponentTextureLevel β€œ0.000000”
SET weatherDensity β€œ0.000000”
SET RAIDweatherDensity β€œ3.000000”
SET graphicsTextureResolution β€œ2”
SET graphicsTextureFiltering β€œ3”
SET graphicsProjectedTextures β€œ1”
SET graphicsViewDistance β€œ3”
SET graphicsEnvironmentDetail β€œ3”
SET graphicsGroundClutter β€œ3”
SET graphicsShadowQuality β€œ1”
SET graphicsLiquidDetail β€œ2”
SET graphicsSunshafts β€œ1”
SET graphicsParticleDensity β€œ1”
SET graphicsSSAO β€œ1”
SET graphicsDepthEffects β€œ1”
SET graphicsLightingQuality β€œ1”
SET graphicsOutlineMode β€œ1”
SET raidGraphicsTextureResolution β€œ3.000000”
SET raidGraphicsTextureFiltering β€œ6.000000”
SET raidGraphicsProjectedTextures β€œ2.000000”
SET raidGraphicsViewDistance β€œ7”
SET raidGraphicsEnvironmentDetail β€œ7”
SET raidGraphicsGroundClutter β€œ7”
SET raidGraphicsShadowQuality β€œ4.000000”
SET raidGraphicsLiquidDetail β€œ3.000000”
SET raidGraphicsSunshafts β€œ3.000000”
SET raidGraphicsParticleDensity β€œ3.000000”
SET raidGraphicsSSAO β€œ4.000000”
SET raidGraphicsDepthEffects β€œ4.000000”
SET raidGraphicsLightingQuality β€œ3.000000”
SET raidGraphicsOutlineMode β€œ3.000000”
SET playIntroMovie β€œ7”
SET Sound_MusicVolume β€œ0.10000000149012”
SET Sound_AmbienceVolume β€œ0.30000001192093”
SET ffxDeath β€œ0”
SET ffxGlow β€œ0”
SET engineSurvey β€œ6”
SET Gamma β€œ1.000000”
SET gameTip β€œ12”
SET spellClutterRangeConstant β€œ10.000000”
SET spellClutterRangeConstantRaid β€œ30.000000”
SET CACHE-WQST-QuestV2RecordCount β€œ31622”
SET CACHE-WQST-QuestV2HotfixCount β€œ2”
SET CACHE-WQST-QuestObjectiveRecordCount β€œ30915”
SET CACHE-WQST-QuestObjectiveHotfixCount β€œ1”
SET CACHE-WQST-QuestObjectiveXEffectRecordCount β€œ8691”
SET CACHE-WQST-QuestObjectiveXEffectHotfixCount β€œ0”
SET CACHE-WGOB-GameObjectsRecordCount β€œ60743”
SET CACHE-WGOB-GameObjectsHotfixCount β€œ0”
SET maxFPS β€œ0”
SET maxFPSBk β€œ0”
SET RenderScale β€œ1”
SET hdPlayerModels β€œ0”
SET uiScale β€œ0.64999997615814”
SET useUiScale β€œ1”
SET gxCursor β€œ0”
SET mouseSpeed β€œ0.5”
SET expandUpgradePanel β€œ0”
SET seenConfigurationWarnings β€œ64”
SET Sound_MasterVolume β€œ0.18100000917912”

Please someone help me, I would really love to get back into areas.
If you are wondering the mouse I am using, it is a Razer Orochi 2011 or 2013 i do not remember tbh.


#2

I was bored and have yet to get a response on here so I tried messing with some addons for cursors in wow so at least i could have a trail so that i could get an idea of where the mouse pointer is… that got me no where so I went into the settings for config and changed 1 thing and fixed my problem completely. I took "SET gxCursor β€œ0"” and change the β€œ0” to β€œ1” and now I have no jumping of the mouse and i can see the mouse completely. I hope this is able to help any one else on here. I also changed the runner to staging 3.2 but that did nothing until i changed the 0 to a 1.


#3

a few points to add:

  • about your post:
    • please use a https://en.wikipedia.org/wiki/Pastebin for big config files and logs and stuff like that (so people don’t have to scroll across it to see the remainder of the posts)
    • and please use the backtick (`) to enclose small pieces of code, for example: SET gxCursor "0" instead of β€œSET gxCursor β€œ0””, just to make it easier to read (because it can be a bit confusing to just have a bit of code in a normal sentence without β€œmarking” it as such, also that makes it monospace font, which looks better for code; and outside of a list it would actually also have a differently colored background, but that styling’s broken for lists on this site).
    • also you might want to edit your post and just put [SOLVED] in front of the title (and maybe even changing it to β€œ[SOLVED] Mouse cursor vanishing in WoW” or something like that so it’s a bit more descriptive when glancing over the lists/search results/etc) so people can see there’s no need for any more work here and people searching for it know there might be a solution to their problems here.
  • your layering idea isn’t really what’s going on in 3d games, essentially what they just do is draw what you can see in the world and then actually paint the UI over it (by literally drawing to the same spot twice, discarding the color info of the first pass on the second).
  • if changing gxCursor helped it’s some problem with the way WoW tries to render the β€œhardware cursor” (just google β€œhardware cursor WoW” and see how many people have had all sorts of problems with that since WoW exists :stuck_out_tongue: )

essentially the idea of a hardware cursor is your GPU actually know where your cursor is supposed to be and what to look like so it can just paint it over everything all the time instead of the program actually having to draw it in its UI drawing step, therefore reducing input lag a bit (e.g. so the mouse doesn’t feel slower when the framerate drops a bit).

but there’s all kinds of hardware, OS or software based stuff and combination thereof which can go wrong and cause it to just not show up (or only sometimes, as was the case for you), so if it works it’s great but yeah many people have to turn such features off because they don’t.