Back to the main site

Strange bug With DXVK!


#1

When I choose to enable DXVK with any game that support DXVK, the game will not start at all. But if I disable DXVK, the game will start without any problem (with DXVK working)!

So If I want to run any game with DXVK turned on, I turn it off otherwise the game will not work at all!

This is a minor bug but it needs to be fixed, because it will drive new Lutris users crazy.


#2

Have you got vulkan installed? check your package manager, or check out this guide https://github.com/lutris/lutris/wiki/How-to:-DXVK


#3

Check versions. in the DXVK_HUD enviroment variable, under System Options for your game, put “version” to check what dxvk version you’re using.

Example: “DXVK_HUD| fps,version” or simply “DXVK_HUD| version” (the bar represents the bar in the UI).

When you activate DXVK on your runner options, Lutris puts DXVK’s DLLs and changes wine settings to make those DLLs override Wine’s defaults.

I suppose you already have DXVK overriden in your default wine settings and you already have DXVK’s DLLs in your wineprefix. When you disable, you’re using those. When you enable, you’re trying to use new ones that are possible incompatible with your system.

Check DXVK’s page to see Driver Support and test older versions for compatibility


#5

I removed DXVK from the default Wine and when I turned DXVK off, I couldn’t run any game using DXVK, and when I truned it on, no game will start even when I change Wine version.

I will turn it off from all games, and install it manually!


#6

You’re probably better picking a suitable DXVK version for your graphics card/driver.

If you do it manually, it’s the same as pressing the Lutris button, honestly.

But then, again, if you have a working setup, let it be and play the games.


#7

Fine with me. Cheers.