Back to the main site

Stop lutris from launching on startup

Hey,

I’ve seen many posts about people complaining about Lutris not launching, but what I want it’s just the opposite xDD
Lutris launches everytime I turn on the PC, which is something I don’t want. The problem is that I can’t find a way to stop it from doing that (I’m new on linux btw, currently using Manjaro). I checked on the program itself and in systemd but nothing (On systemd the program appeared because it was open, but I couldn’t disable it or anything, just kill the process).

Many thanks!

Do you use XFCE?

nope, im on kde plasma

I use KDE on Manjaro too. Open the System Settings then look for Autostart. (It is under Workspace - Startup and Shutdown - Autostart) It should list the programs you have set to autostart. If it is there then remove it. If it is not there then something else must be starting it.

Hey, thank you for replying,

I looked there before posting this and that list was empty, in fact, I added discord the second I discovered that tab xD

Can you check
~/.config/autostart
~/.config/autostart-scripts

Lutris is not there. BUT, it now stopped launching on startup despite not having done absolutely nothing about it (bc I couldn’t be able to find anything in the config), so thank you guys for trying to help me!

I’m currently having this same issue and like OP said Lutris does not appear in the autostart list in the KDE Plasma settings. I’m using vanilla Arch and KDE Plasma as well so maybe the issue relates to that in some way.

A lot of these desktop environments have a “save session” that is enabled by default. So when you log in again, it starts the programs that were running when you logged off. You won’t see this in autostart.

For KDE/Plasma, in the control center, I think it’s something like Startup and Shutdown and there is a setting for session saving behaviour. One of them is “start with a new session” which disables it. It can also be manual if I recall. Save a session once, and it will keep loading it at startup.

That seems to have fixed it for me, its weird because Lutris was the only application I noticed this ever happen to. Thanks for the help!