Back to the main site

Steam runner proton access error when running custom exe

Hello. I own Gothic II in Steam. Running games from steam works. What I’m trying to do is to install additional addon for the game.

Problem is that I can’t run anything other than original files using native proton. If I switch to wine runner it works.

I want to install custom mods and high-res textures for Gothic II and Risen in default Proton prefix and run games using native Proton.

Can someone tell me how to proceed?

logs

Running /mnt/Ret.exe steam://rungameid/39510
Traceback (most recent call last):
File “/usr/share/lutris/bin/lutris-wrapper”, line 237, in
main()
File “/usr/share/lutris/bin/lutris-wrapper”, line 120, in main
initial_pid = subprocess.Popen(args).pid
File “/usr/lib/python3.8/subprocess.py”, line 854, in init
self._execute_child(args, executable, preexec_fn, close_fds,
File “/usr/lib/python3.8/subprocess.py”, line 1702, in _execute_child
raise child_exception_type(errno_num, err_msg, err_filename)
PermissionError: [Errno 13] Permission denied: ‘/mnt/Ret.exe’

Settings

You can’t configure internal operation of Steam from Lutris UI; Steam doesn’t provide such an option. The executable in question is probably Steam executable itself.

Why are you trying to run a file located in /mnt/? If that’s where you mounted your CD disk/image, you should mount it into a subfolder instead (e.g. /mnt/cdrom). And of course you shouldn’t try to run it instead of the game.

What you should do is create a Wine config for the game, listing its wineprefix as the Proton wine bottle (${STEAM_LIBRARY_PATH}/steamapps/compatdata/${STEAM_GAME_ID}/pfx) and the Wine version being the Proton version you run the game with (Proton should be present in the Wine versions list); then you can use “Run EXE inside wine prefix” option from context menu or right-side panel (when the Wine game config is selected) to run your mods installer.

And if you need to change the executable that the game runs with, you’ll have to try your luck with Steam game launch options setting. Or possibly try to substitude the game executable or something if that doesn’t work out…

Why are you trying to run a file located in /mnt/ ? If that’s where you mounted your CD disk/image, you should mount it into a subfolder instead (e.g. /mnt/cdrom ). And of course you shouldn’t try to run it instead of the game.

That’s the mod installer. I usually mount iso images in /mnt if I need to install something. Wine detects it automatically in that folder. What the installer does it updates some game files and replaces main game exe. Gothic II is old and it was improved by modders since time of a release. Adding DirectX11 render, for example.

I tried to install mod from iso and then launch game exe as usual.

Anyway, I ended up buying another copy of the game in gog.com and tried to install it with lutris wine version. Gothic II works, but modded version does not. Mod was still developed since I played it last time and I think they broke wine compatibility. It shows menu, load screen and game crashes without any errors in the terminal :slight_smile:

Too bad for me, because it extends game world, adds new factions and a lot of new quests. I don’t see the point in replaying official version for now.