Steam for windows game only - 32 bit version

Hi all,

I try to install “steam for windows”

But the script seams to be for 64 bits only, because I can’t access to " Wine configuration " in 32 bits :

Drive C: total 28
drwxr-xr-x  7 regis regis 4096 févr.  2 17:32 .
drwxr-xr-x  4 regis regis 4096 févr.  2 17:33 ..
drwxr-xr-x  3 regis regis 4096 févr.  2 17:32 ProgramData
drwxr-xr-x  6 regis regis 4096 févr.  2 17:32 Program Files
drwxr-xr-x  7 regis regis 4096 févr.  2 17:32 Program Files (x86)
drwxr-xr-x  4 regis regis 4096 févr.  2 17:32 users
drwxr-xr-x 21 regis regis 4096 févr.  2 17:32 windows

Registry info:
warning: /home/regis/.local/share/lutris/runners/wine/lutris-fshack-6.21-6-x86_64/bin/wine cmd.exe /c echo '%AppData%' returned empty string, error message "wine: WINEARCH set to win32 but '/home/regis/Games/steam32' is a 64-bit installation." 
Monitored process exited.
Initial process has exited (return code: 256)
All monitored processes have exited.
Exit with returncode 256

I need to access to programs in Wine with 32 bits architecture (for “windows media player” and try too with “directx9”) : so far I can’t run the old game " R.U.S.E " which is “windows only” …

Any workaround available to run Steam script in 32 bits ?

Thanks a lot

So, you are using a 32bits linux, or somehow you are forcing the env var WINEARCH to be “win32”?

Because I clicked on Install on that script, and it just works. Keep in mind that just because one particular program requires win32 or win64, doesn’t mean everything has to be one or the other. If you are using a 64bit Linux, you can use both win64 or win32, depending on the game. If you are using a 32bit linux, then you are stuck to only win32 (as far as I know. I haven’t used a 32bit linux for a while).

Putting that aside, according to protondb, it seems R.U.S.E works fine there (following the instructions about DXsetup), so maybe you could try that, using native steam + proton.

Thanks for your answer chrll :slight_smile:
on Lutris the game launch the splash video, but then it is unable to get access to the game menus : it freezes and nothing is possible to unlock that… I tried various options but without success, it is very close to work well. I tried to DirectX9, vc++ libraries, and so on, but nothing go well. It’s frustrating.

So I turned to Steam Play / proton 5.0 as you advice me : the problem is reversed against Lutris.
I mean, there is an error when launching the game due to “Windows Media Player” is missing, but after I accept the message : I can access to the game menus.
But with Steam/Proton, it can’t play the videos between 2 campaigns, which explain the history… but the game is playable nevertheless.

Thank you !