Steam Deck: "Missing Vulkan Libraries" after update to 0.5.13 (flatpak)

Hi all! I’ve updated Lutris (Flatpak version) on my Steam Deck from 0.5.12 to 0.5.13 and now I get the “Missing Vulkan Libraries” error in the runner options of all installed games. When I try to launch one, it says “Wine is not installed on your system”. It worked fine before the update.

Any ideas how to fix or debug this? Running vulkaninfo on the Deck show the usual (fine) output. Wine is installed. I’ve also tried “lutris-GE-Proton8-8” but without success.

OK, after some more research, I tried to run Lutris in the CLI and got this:

(1)(deck@steamdeck ~)$ flatpak run net.lutris.Lutris

(process:2): Gdk-WARNING **: 11:17:17.997: No such backend: *
WARNING:root:Missing extension org.gnome.Platform.Compat.i386, see

I checked for that package and found it to be installed:

(139)(deck@steamdeck ~)$ flatpak list | grep org.gnome.Platform.Compat.i386
i386	org.gnome.Platform.Compat.i386		43	flathub	system

However, it wasn’t the latest version (which is 44), so I installed it:

(deck@steamdeck ~)$ sudo flatpak install flathub org.gnome.Platform.Compat.i386
[sudo] password for deck: 
Looking for matches…
Similar refs found for ‘org.gnome.Platform.Compat.i386’ in remote ‘flathub’ (system):

   1) runtime/org.gnome.Platform.Compat.i386/x86_64/3.34
   2) runtime/org.gnome.Platform.Compat.i386/x86_64/3.36
   3) runtime/org.gnome.Platform.Compat.i386/x86_64/3.38
   4) runtime/org.gnome.Platform.Compat.i386/x86_64/40
   5) runtime/org.gnome.Platform.Compat.i386/x86_64/41
   6) runtime/org.gnome.Platform.Compat.i386/x86_64/42
   7) runtime/org.gnome.Platform.Compat.i386/x86_64/43
   8) runtime/org.gnome.Platform.Compat.i386/x86_64/44

Which do you want to use (0 to abort)? [0-8]: 8

        ID                                       Branch           Op           Remote           Download
 1. [✓] org.gnome.Platform.Compat.i386           44               i            flathub          214.2 MB / 202.1 MB

Installation complete.

And now it’s working again!

I’m leaving this solution here, just in case others have the same issue. But I STRONGLY suggest that you add a graphical error message / pop-up when starting Lutris! And also please add a list of dependencies (and their required versions!) to GitHub - flathub/net.lutris.Lutris. Afair, there used to be one, but now it’s gone…

P.S. : here’s how to remove the old Flatpak packages after the update, in order to reclaim some of that precious space on the Deck:

  1. Make sure that it’s is not needed anymore:
(deck@steamdeck ~)$ flatpak list --app --app-runtime=org.gnome.Platform.Compat.i386/x86_64/43
(deck@steamdeck ~)
  1. If the command above gives no output, remove the old package:
(deck@steamdeck ~)$ sudo flatpak uninstall org.gnome.Platform.Compat.i386/x86_64/43

        ID                                     Branch         Op
 1. [-] org.gnome.Platform.Compat.i386         43             r

Uninstall complete.
  1. Now that you’re already here, let Flatpak remove all packages that are currently unused:
    sudo flatpak uninstall --unused

Note that the last command does not work for all types of packages, e. g. it didn’t recognize org.gnome.Platform.Compat.i386/x86_64/43 as unused (yeah, Flatpak is weird).